Currently, `compression` table options are inconsistent with the likes of it (table `compaction`, keyspace `replication`).
I suggest we change it for 3.0, like we did change `caching` syntax for 2.1 (while continuing to accept the old syntax for a release).
I recommend the following changes:
1. rename `sstable_compression` to `class`, to make it consistent `compression` and `replication`
2. rename `chunk_length_kb` to `chunk_length_in_kb`, to match `memtable_flush_period_in_ms`, or, alternatively, to just `chunk_length`, with `memtable_flush_period_in_ms` renamed to `memtable_flush_period` - consistent with every other CQL option everywhere else
3. add a boolean `enabled` option, to match `compaction`. Currently, the official way to disable comression is an ugly, ugly hack (see