Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: 1.2.7
    • Component/s: None
    • Labels:
      None

      Description

      Steps to be able to reproduce it :

      • have a heap of 1Gb
      • have a saved key cache without the SSTables

      When looking at KeyCacheSerializer.serialize : it always writes a Boolean
      When looking at KeyCacheSerializer.deserialize : no Boolean is read if SSTable is missing...

      In case of a promoted index, RowIndexEntry.serializer.skip(...) should be called rather than RowIndexEntry.serializer.skipPromotedIndex(...) (again for symmetry between serialization/deserialization)

      Attached is a proposed patch

      1. 5706-OOM-while-loading-key-cache-at-startup.patch
        0.8 kB
        Fabien Rousseau
      2. 5706-v2-txt
        2 kB
        Jonathan Ellis

        Activity

        jbellis Jonathan Ellis added a comment -

        (setting affects- to 1.2.5 b/c suspect was introduced by CASSANDRA-5492)

        jbellis Jonathan Ellis added a comment -

        (actually, annotate says this dates back to CASSANDRA-3762)

        jbellis Jonathan Ellis added a comment -

        Your analysis is correct; attached is slightly revised patch to emphasize that we already read exactly one boolean

        jbellis Jonathan Ellis added a comment -

        LGTY Fabien?

        frousseau Fabien Rousseau added a comment -

        Sorry for the delay.

        Yep, it looks good to me.

        jbellis Jonathan Ellis added a comment -

        committed

        tomvandenberge Tom van den Berge added a comment -

        I'm having this problem again since I've upgraded to 1.2.10.


          People

          • Assignee:
            frousseau Fabien Rousseau
            Reporter:
            frousseau Fabien Rousseau
            Reviewer:
            Jonathan Ellis
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development