Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: 1.2.1
    • Component/s: Core
    • Labels:
      None
    • Environment:

      Mac OSX, DS Java Driver, apache-cassandra-1.2.0-src downloaded from project Jan 2, 2013

      Description

      To reproduce:

      ./cqlsh
      Connected to Test Cluster at localhost:9160.
      [cqlsh 2.3.0 | Cassandra 1.2.0-SNAPSHOT | CQL spec 3.0.0 | Thrift protocol 19.35.0]
      Use HELP for help.
      cqlsh> create keyspace music with replication =

      {'CLASS' : ... 'SimpleStrategy', 'replication_factor' : 3}

      ;
      cqlsh> use music
      ... ;
      cqlsh:music> CREATE TABLE songs (
      ... id uuid PRIMARY KEY,
      ... title text,
      ... album text,
      ... artist text,
      ... data blob
      ... );
      cqlsh:music> insert into songs (id, title, artist, album) values ('a3e64f8f-bd44-4f28-b8d9-6938726e34d4', 'La Grange', 'ZZ Top', 'Tres Hombres');
      cqlsh:music> insert into songs (id, title, artist, album) values ('8a172618-b121-4136-bb10-f665cfc469eb', 'Moving in Stereo', 'Fu Manchu', 'We Must Obey');
      cqlsh:music> insert into songs (id, title, artist, album) values ('62c36092-82a1-3a00-93d1-46196ee77204', 'Outside Woman Blues', 'Back Door Slam', 'Roll Away');
      cqlsh:music> CREATE TABLE song_tags (
      ... id uuid,
      ... tag_name text,
      ... PRIMARY KEY (id, tag_name)
      ... );
      cqlsh:music> select * from song_tags;
      cqlsh:music> INSERT INTO song_tags (id, tag_name) VALUES ('a3e64f8f-bd44-4f28-b8d9-6938726e34d4', 'blues');
      cqlsh:music> INSERT INTO song_tags (id, tag_name) VALUES ('8a172618-b121-4136-bb10-f665cfc469eb', 'covers');
      cqlsh:music> INSERT INTO song_tags (id, tag_name) VALUES ('a3e64f8f-bd44-4f28-b8d9-6938726e34d4', '1973');
      cqlsh:music> INSERT INTO song_tags (id, tag_name) VALUES ('8a172618-b121-4136-bb10-f665cfc469eb', '2007');
      cqlsh:music> select * from song_tags;

      id | tag_name
      -------------------------------------+---------
      a3e64f8f-bd44-4f28-b8d9-6938726e34d4 | 1973
      a3e64f8f-bd44-4f28-b8d9-6938726e34d4 | blues
      8a172618-b121-4136-bb10-f665cfc469eb | 2007
      8a172618-b121-4136-bb10-f665cfc469eb | covers

      cqlsh:music> drop table song_tags;
      cqlsh:music> ALTER TABLE songs ADD tags set<text>;
      TSocket read 0 bytes

      1. OOB.txt
        10 kB
        Kristine Hahn
      2. 5117.txt
        1.0 kB
        Dave Brosius
      3. 5117-v2.txt
        2 kB
        Sylvain Lebresne

        Activity

        Aleksey Yeschenko added a comment -

        Looks like it could be related to CASSANDRA-5064.

        Kristine Hahn added a comment -

        system.log

        Sylvain Lebresne added a comment -

        I don't think the attached patch is correct (that is, it fixes the fact that componentIndex be set to a negative value, but it's not the correct fix). The problem is that in the case where we add a collection but we had not collection previous, we should not do the component-- at all. Attaching a v2 to fix that.

        Dave Brosius added a comment -

        +1

        Sylvain Lebresne added a comment -

        Committed, thanks


          People

          • Assignee:
            Sylvain Lebresne
            Reporter:
            Kristine Hahn
            Reviewer:
            Dave Brosius
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development