Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:

      Description

      CASSANDRA-1740 broke cache saving on Windows.

      1. 3566.patch
        4 kB
        Sylvain Lebresne

        Activity

        jbellis Jonathan Ellis added a comment -

        All the cache tests fail with an exception like this:

            [junit] Testcase: testKeyCacheLoad(org.apache.cassandra.db.KeyCacheTest):   Caused an ERROR
            [junit] java.lang.RuntimeException: java.io.IOException: Unable to rename build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache7847563715233372577.tmp to build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache
            [junit] java.util.concurrent.ExecutionException: java.lang.RuntimeException: java.io.IOException: Unable to rename build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache7847563715233372577.tmp to build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache
            [junit]     at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:222)
            [junit]     at java.util.concurrent.FutureTask.get(FutureTask.java:83)
            [junit]     at org.apache.cassandra.db.KeyCacheTest.testKeyCacheLoad(KeyCacheTest.java:87)
            [junit] Caused by: java.lang.RuntimeException: java.io.IOException: Unable to rename build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache7847563715233372577.tmp to build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache
            [junit]     at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:37)
            [junit]     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
            [junit]     at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
            [junit]     at java.util.concurrent.FutureTask.run(FutureTask.java:138)
            [junit]     at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            [junit]     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            [junit]     at java.lang.Thread.run(Thread.java:662)
            [junit] Caused by: java.io.IOException: Unable to rename build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache7847563715233372577.tmp to build\test\cassandra\saved_caches\KeyCacheSpace-Standard3-KeyCache
            [junit]     at org.apache.cassandra.cache.AutoSavingCache$Writer.saveCache(AutoSavingCache.java:265)
            [junit]     at org.apache.cassandra.db.compaction.CompactionManager$10.runMayThrow(CompactionManager.java:907)
            [junit]     at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
            [junit]
            [junit]
            [junit] Test org.apache.cassandra.db.KeyCacheTest FAILED
        
        jbellis Jonathan Ellis added a comment -

        I'd be totally fine with just ripping the cancellation code out of cache saving. Cache saving will be very fast compared to most actual compactions.

        slebresne Sylvain Lebresne added a comment -

        I'm totally with that too. Patch attach to rip that part.

        jbellis Jonathan Ellis added a comment -

        +1 (went ahead and committed since this has been bugging me)


          People

          • Assignee:
            slebresne Sylvain Lebresne
            Reporter:
            jbellis Jonathan Ellis
            Reviewer:
            Jonathan Ellis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development