Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      If a counter write returns a TimeoutException, the client cannot retry its write without risking an overcount.

      One idea to fix this would be to allow the client to specify a replay ID with each counter write unique to the write. If the write timeout, the client would resubmit the write with the same replay ID and the system would ensure that write is only replayed if the previous write was not persisted.

      Of course, the last part of this ("the system would ensure ...") is the hard part. Still worth exploring I believe.

        Activity

        Sylvain Lebresne created issue -
        Sylvain Lebresne added a comment -

        Closing this one as this is a duplicate of CASSANDRA-2495

        Sylvain Lebresne made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Duplicate [ 3 ]
        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12616910 ] patch-available, re-open possible [ 12752872 ]
        Gavin made changes -
        Workflow patch-available, re-open possible [ 12752872 ] reopen-resolved, no closed status, patch-avail, testing [ 12758505 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        39d 1h 52m 1 Sylvain Lebresne 25/Jul/11 19:03

          People

          • Assignee:
            Unassigned
            Reporter:
            Sylvain Lebresne
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development