Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Duplicate
    • Fix Version/s: None
    • Component/s: CQL
    • Labels:
      None

      Description

      We would like to support TTLs for counter columns, with the behaviour that the count is unset when the TTL expires, and that every mutation to the counter updates the TTL deadline.

      This would allow for interesting rate-limiting usecases, automatic cleanup of time-series data, and API consistency.

        Activity

        kingryan Ryan King added a comment -
        stuhood Stu Hood added a comment -

        Not targeting to a particular version, because we're exploring all options first.


          People

          • Assignee:
            Unassigned
            Reporter:
            stuhood Stu Hood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development