Cassandra
  1. Cassandra
  2. CASSANDRA-1830

ReadResponseResolver might miss an inconsistency

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Fix Version/s: 0.6.9, 0.7.0 rc 3
    • Component/s: Core
    • Labels:
      None

      Description

      Rather than comparing the digests of all the digest requests to one another, the last one seen "wins" and is compared to the digest of each version seen from a data request.

      1. 1830_0.7.txt
        4 kB
        Sylvain Lebresne
      2. 1830.txt
        3 kB
        Jonathan Ellis

        Activity

        Jonathan Ellis created issue -
        Jonathan Ellis added a comment -

        Patch based on Randall Leeds's from CASSANDRA-982.

        Jonathan Ellis made changes -
        Field Original Value New Value
        Attachment 1830.txt [ 12465620 ]
        Jonathan Ellis made changes -
        Fix Version/s 0.7.0 [ 12315950 ]
        Fix Version/s 0.7.0 rc 2 [ 12315581 ]
        Jonathan Ellis made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Assignee Jonathan Ellis [ jbellis ]
        Reviewer slebresne
        Jonathan Ellis made changes -
        Affects Version/s 0.6.9 [ 12315556 ]
        Affects Version/s 0.7.0 [ 12315950 ]
        Sylvain Lebresne added a comment -

        +1 on v6 version (very minor comment: the import of ColumnFamily in DigestMismatchException.java is unnecessary)

        Also attaching a port to 0.7.

        Sylvain Lebresne made changes -
        Attachment 1830_0.7.txt [ 12466326 ]
        Jonathan Ellis made changes -
        Fix Version/s 0.6.9 [ 12315556 ]
        Affects Version/s 0.6 [ 12314361 ]
        Affects Version/s 0.6.9 [ 12315556 ]
        Affects Version/s 0.7.0 [ 12315950 ]
        Jonathan Ellis added a comment -

        committed, thanks!

        Jonathan Ellis made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Assignee Jonathan Ellis [ jbellis ] Randall Leeds [ tilgovi ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Cassandra-0.6 #23 (See https://hudson.apache.org/hudson/job/Cassandra-0.6/23/)
        ReadResponseResolver check digests against each other
        patch by Randall Leeds and jbellis; reviewed by slebrense for CASSANDRA-1830

        Hudson added a comment -

        Integrated in Cassandra-0.6 #32 (See https://hudson.apache.org/hudson/job/Cassandra-0.6/32/)
        fix NPE regression caused by CASSANDRA-1830
        patch by jbellis; reviewed by mdennis and tjake

        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12539448 ] patch-available, re-open possible [ 12752538 ]
        Gavin made changes -
        Workflow patch-available, re-open possible [ 12752538 ] reopen-resolved, no closed status, patch-avail, testing [ 12755412 ]

          People

          • Assignee:
            Randall Leeds
            Reporter:
            Jonathan Ellis
            Reviewer:
            Sylvain Lebresne
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development