Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-1790

Booting fails on Windows 7/Windows 2003 because of a file rename failure

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Fix Version/s: 0.7.0 rc 2
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 7 (64-bit), Windows 2003 (32-bit)

      Description

      Cassandra 0.7.0 rc will not boot on Windows 7 and Windows 2003 because of a file rename failure. The logging:

       INFO [FlushWriter:1] 2010-11-25 17:12:43,796 Memtable.java (line 155) Writing Memtable-LocationInfo@691789110(435 bytes, 8 operations)
      ERROR [FlushWriter:1] 2010-11-25 17:12:43,993 AbstractCassandraDaemon.java (line 90) Fatal exception in thread Thread[FlushWriter:1,5,main]
      java.io.IOError: java.io.IOException: rename failed of d:\cassandra\data\system\LocationInfo-e-1-Data.db
      	at org.apache.cassandra.io.sstable.SSTableWriter.rename(SSTableWriter.java:214)
      	at org.apache.cassandra.io.sstable.SSTableWriter.closeAndOpenReader(SSTableWriter.java:184)
      	at org.apache.cassandra.io.sstable.SSTableWriter.closeAndOpenReader(SSTableWriter.java:167)
      	at org.apache.cassandra.db.Memtable.writeSortedContents(Memtable.java:161)
      	at org.apache.cassandra.db.Memtable.access$000(Memtable.java:49)
      	at org.apache.cassandra.db.Memtable$1.runMayThrow(Memtable.java:174)
      	at org.apache.cassandra.utils.WrappedRunnable.run(WrappedRunnable.java:30)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: rename failed of d:\cassandra\data\system\LocationInfo-e-1-Data.db
      	at org.apache.cassandra.utils.FBUtilities.renameWithConfirm(FBUtilities.java:359)
      	at org.apache.cassandra.io.sstable.SSTableWriter.rename(SSTableWriter.java:210)
      	... 12 more
       INFO [main] 2010-11-29 09:16:36,219 AbstractCassandraDaemon.java (line 73) Heap size: 1067253760/1067253760
      
      1. 1790.txt
        2 kB
        Jonathan Ellis

        Activity

        jbellis Jonathan Ellis added a comment -

        patch to close file handle used for post-flush truncate, which will allow the rename to complete on Windows

        mdennis Matthew F. Dennis added a comment -

        +1

        jbellis Jonathan Ellis added a comment -

        committed

        hudson Hudson added a comment -

        Integrated in Cassandra-0.7 #70 (See https://hudson.apache.org/hudson/job/Cassandra-0.7/70/)


          People

          • Assignee:
            jbellis Jonathan Ellis
            Reporter:
            rockxwre Ramon Rockx
            Reviewer:
            Matthew F. Dennis
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development