Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-16541

LGPL dependency in cassandra-all 3.11.10

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Not A Problem
    • Fix Version/s: 2.2.20, 3.0.25, 3.11.11, 4.0
    • Component/s: Build
    • Labels:
      None
    • Bug Category:
      Correctness
    • Severity:
      Normal
    • Complexity:
      Normal
    • Discovered By:
      User Report
    • Platform:
      All
    • Impacts:
      None

      Description

      Dear Cassandra devs.

      While integrating Cassandra in Apache Hop functionality we found out that the cassandra-all maven package drags in an older version of jboss-logging via reporter-config3:

      +- org.apache.cassandra:cassandra-all:jar:3.11.10:compile
      |  +- com.addthis.metrics:reporter-config3:jar:3.0.3:compile
      |  |  +- com.addthis.metrics:reporter-config-base:jar:3.0.3:compile
      |  |  \- org.hibernate:hibernate-validator:jar:4.3.0.Final:compile
      |  |     +- javax.validation:validation-api:jar:1.0.0.GA:compile
      |  |     \- org.jboss.logging:jboss-logging:jar:3.1.0.CR2:compile
      
      

      jboss-logging 3.1.0.CR2 is from November 2011 and the library only changed to APL in 2012.

      https://github.com/jboss-logging/jboss-logging/blob/master/src/main/resources/META-INF/LICENSE.txt

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                bereng Berenguer Blasi
                Reporter:
                mcasters Matt Casters
                Authors:
                Berenguer Blasi
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: