Cassandra
  1. Cassandra
  2. CASSANDRA-1430

SSTable statistics causing intermittent CL test failures in trunk.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Fix Version/s: 0.7 beta 2
    • Component/s: Core
    • Labels:
      None

      Description

      [junit] Testcase: testCleanup(org.apache.cassandra.db.CommitLogTest): FAILED
      [junit] 2 != 1
      [junit] junit.framework.AssertionFailedError: 2 != 1
      [junit] at org.apache.cassandra.db.CommitLogTest.testCleanup(CommitLogTest.java:69)
      [junit]
      [junit]

      I see this 1-2 times a day.

      1. 1430.txt
        22 kB
        Brandon Williams

        Activity

        Gary Dusbabek created issue -
        Gary Dusbabek added a comment -
        Jonathan Ellis added a comment -

        this is caused by sstable statistics being written after the flush (see ssTableWriter.closeAndOpenReader)

        is it time to admit that storing sstable info, in sstables, wasn't a good idea?

        Jonathan Ellis added a comment -

        (this isn't just a test issue, i'm pretty sure it could bork drain, too)

        Gary Dusbabek added a comment -

        >is it time to admit that storing sstable info, in sstables, wasn't a good idea?
        What if statistics operations ran on its own stage that could be halted at critical moments (flushing, for example).

        Jonathan Ellis added a comment -

        it already feels like a rather ugly set of workarounds, and maybe it's time to cut our losses

        Gary Dusbabek added a comment -

        I can't disagree. CASSANDRA-1382 should be on the list of things that get reverted when we figure out a better way of statistics.

        Jonathan Ellis added a comment -

        Let's just create an EstimatedHistogram serializer and write out one for each of the row sizes and column counts. SSTable.components will have to be updated.

        Jonathan Ellis made changes -
        Field Original Value New Value
        Summary Intermittent CL test failures in trunk. SSTable statistics causing intermittent CL test failures in trunk.
        Issue Type Test [ 6 ] Bug [ 1 ]
        Assignee Matthew F. Dennis [ mdennis ]
        Component/s Core [ 12312978 ]
        Jonathan Ellis made changes -
        Assignee Matthew F. Dennis [ mdennis ] Brandon Williams [ brandon.williams ]
        Brandon Williams added a comment -

        Patch to remove sstable stats from the system table, and make them their own sstable component.

        Brandon Williams made changes -
        Attachment 1430.txt [ 12453838 ]
        Brandon Williams made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Jonathan Ellis added a comment -

        I'm getting build errors in a couple test classes

        Brandon Williams made changes -
        Attachment 1430.txt [ 12453838 ]
        Brandon Williams added a comment -

        Oops, I'd forgotten about more tests being added due to CASSANDRA-1155's problems. Patch updated to fix tests.

        Brandon Williams made changes -
        Attachment 1430.txt [ 12453855 ]
        Jonathan Ellis added a comment -

        +1

        Brandon Williams added a comment -

        Committed.

        Brandon Williams made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Jonathan Ellis added a comment -

        this broke StreamingTransferTest (easy to miss in the ant output because it is a timeout rather than a failure)

        Jonathan Ellis made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Jonathan Ellis added a comment -

        fixed by CASSANDRA-1471

        Jonathan Ellis made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Reviewer jbellis
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Cassandra #533 (See https://hudson.apache.org/hudson/job/Cassandra/533/)

        Gavin made changes -
        Workflow no-reopen-closed, patch-avail [ 12518895 ] patch-available, re-open possible [ 12752408 ]
        Gavin made changes -
        Workflow patch-available, re-open possible [ 12752408 ] reopen-resolved, no closed status, patch-avail, testing [ 12758288 ]

          People

          • Assignee:
            Brandon Williams
            Reporter:
            Gary Dusbabek
            Reviewer:
            Jonathan Ellis
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development