Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-13594

Use an ExecutorService for repair commands instead of new Thread(..).start()

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: 4.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently when starting a new repair, we create a new Thread and start it immediately

      It would be nice to be able to 1) limit the number of threads and 2) reject starting new repair commands if we are already running too many.

      1. 13594.png
        168 kB
        Marcus Eriksson

        Activity

        jkni Joel Knighton added a comment -

        No problem - fix committed as 256a74faa31fcf25bdae753c563fa2c69f7f355c. Thanks!

        krummas Marcus Eriksson added a comment -

        +1, sorry about that, again...

        jkni Joel Knighton added a comment -

        This causes a test failure in DatabaseDescriptorRefTest because of the new Config class - I've pushed a fix here.

        krummas Marcus Eriksson added a comment -

        Committed, thanks

        aweisberg Ariel Weisberg added a comment -

        Unrelated but I did manage to reproduce short_read_test failing after letting it run a lot of times.

        aweisberg Ariel Weisberg added a comment - - edited

        I've noticed that short_read test seems to time out quite a bit. I'll run it locally a bit and see if it reproduces. I think I did before with no luck. This issue might only appear in Apache Jenkins.

        krummas Marcus Eriksson added a comment -

        Still trying to get dtests to run successfully, they seem quite broken right now

        aweisberg Ariel Weisberg added a comment - - edited

        The dtest you started has almost certainly been aged out. https://builds.apache.org/view/A-D/view/Cassandra/job/Cassandra-devbranch-dtest/145/

        I think we need to set up archiving of information from Apache Jenkins since they are throwing away everything after a mere 10 builds.

        krummas Marcus Eriksson added a comment -

        Yes, it is

        Since we are reusing threads in the ExecutorService we need to clear out the tracing state between runs, I have pushed a commit that does that and restarted the dtests.

        aweisberg Ariel Weisberg added a comment -

        Maybe a legit failure?
        thread_count_repair_test (repair_tests.repair_test.TestRepair) ... Build timed out (after 20 minutes). Marking the build as aborted.

        aweisberg Ariel Weisberg added a comment -

        I think it's pretty unlikely there is a test dependency on repair command concurrency, but but maybe run the dtests just to be safe?

        The code itself looks good.

        krummas Marcus Eriksson added a comment - - edited

        https://github.com/krummas/cassandra/commits/marcuse/limit_repair_command_threads

        introduces 2 new config variables:

        • repair_command_pool_size - how many repair commands can we run at the same time
        • repair_command_pool_full_strategy what do we do when the pool is full (queue or reject)

          People

          • Assignee:
            krummas Marcus Eriksson
            Reporter:
            krummas Marcus Eriksson
            Reviewer:
            Ariel Weisberg
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development