For collections and counters, the current syntax to add/remove elements is:
which is fine, though it's already tad annoying to have to repeat myCollection.
But moving forward, with tickets CASSANDRA-7826, we'll start being able to add to nested collections and we'll end up with queries like:
where the repetition is starting to be really annoying and it makes the query less readable.
It's trivial however to add a +=/-= shortcut syntax which would read instead:
As this would just be syntactic sugar, it only requires a few minor addition to the grammar and this would be completely optional: if some users prefer the verbose syntax, that's fine.
Also note that while this will be even more useful after things like CASSANDRA-7826, it's already a nice to have today so it's not dependent on that latter ticket in any way.