Uploaded image for project: 'Cassandra'
  1. Cassandra
  2. CASSANDRA-12129

deb Packages cannot be installed under Ubuntu 16.04 (xenial) due to missing dependency

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Not A Problem
    • Fix Version/s: 2.1.15, 2.2.7, 3.0.6, 3.6
    • Component/s: Packaging
    • Labels:
      None
    • Environment:

      Ubuntu 16.04 (Xenial)

    • Severity:
      Normal

      Description

      The deb packages depend on python-support, which no longer exists in Ubuntu 16.04 (xenial).

      $ sudo apt install cassandra
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:

      The following packages have unmet dependencies:
      cassandra : Depends: python-support (>= 0.90.0) but it is not installable
      Recommends: ntp but it is not going to be installed or
      time-daemon
      E: Unable to correct problems, you have held broken packages.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mshuler Michael Shuler
                Reporter:
                stub Stuart Bishop
                Authors:
                Michael Shuler
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: