Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-9362

Camel CDI component should not require the PAX CDI Camel capability

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.16.1
    • Fix Version/s: 2.16.2, 2.17.0
    • Component/s: camel-cdi
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      The Camel CDI extension requires the PAX CDI Camel CDI extension capability (itself) which leads to having an empty CDI container started by PAX CDI when the camel-cdi bundle is installed in Karaf.

        Attachments

          Activity

            People

            • Assignee:
              antonin.stefanutti Antonin Stefanutti
              Reporter:
              antonin.stefanutti Antonin Stefanutti
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: