Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-8122

camel:run using <useBlueprint> option does not launch camel example project

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.15.0
    • Fix Version/s: None
    • Component/s: examples
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      When we launch the maven camel:run goal with the camel-example-sql-blueprint, the camel project is not started and this OSGI Service error is reported.

      I suspect that some bundles are missing and not loaded by the PoJoSr classloader when the project is started/launched by the camel-maven-plugin

      See line of code

      package org.apache.camel.maven;
      ...
      public class RunMojo extends AbstractExecMojo {
      ...
      
              } else if (usingBlueprintMain) {
                  mainClass = "org.apache.camel.test.blueprint.Main";
                  // must include plugin dependencies for blueprint
                  extraPluginDependencyArtifactId = "camel-test-blueprint";
      

      Error reported on the console

      Caused by: java.lang.RuntimeException: Gave up waiting for service (objectClass=org.apache.camel.CamelContext)
      
      
      [INFO] --- camel-maven-plugin:2.15-SNAPSHOT:run (default-cli) @ camel-example-sql-blueprint ---
      [INFO] Using org.apache.camel.test.blueprint.Main to initiate a CamelContext
      [INFO] Starting Camel ...
      [mel.test.blueprint.Main.main()] MainSupport                    INFO  Apache Camel 2.15-SNAPSHOT starting
      [mel.test.blueprint.Main.main()] Activator                      INFO  Camel activator starting
      [mel.test.blueprint.Main.main()] Activator                      INFO  Camel activator started
      [mel.test.blueprint.Main.main()] BlueprintExtender              INFO  No quiesce support is available, so blueprint components will not participate in quiesce operations
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  Test bundle headers: Bundle-ManifestVersion=2, Bundle-Name=System Bundle, Bundle-SymbolicName=de.kalpatec.pojosr.framework, Bundle-Vendor=kalpatec, Bundle-Version=0.2.1
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.camel.spi.TypeConverterLoader], bundle: org.apache.camel.camel-core [3], symbolicName: org.apache.camel.camel-core
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.camel.camel-blueprint [2], symbolicName: org.apache.camel.camel-blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.proxy.ProxyManager], bundle: org.apache.aries.proxy.impl [19], symbolicName: org.apache.aries.proxy.impl
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.cm.ConfigurationAdmin], bundle: org.apache.felix.configadmin [28], symbolicName: org.apache.felix.configadmin
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.felix.cm.PersistenceManager], bundle: org.apache.felix.configadmin [28], symbolicName: org.apache.felix.configadmin
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.cm.ManagedServiceFactory], bundle: org.apache.felix.fileinstall [29], symbolicName: org.apache.felix.fileinstall
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.cm.ConfigurationListener, org.apache.felix.fileinstall.ArtifactListener, org.apache.felix.fileinstall.ArtifactInstaller], bundle: org.apache.felix.fileinstall [29], symbolicName: org.apache.felix.fileinstall
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.url.URLStreamHandlerService], bundle: org.apache.felix.fileinstall [29], symbolicName: org.apache.felix.fileinstall
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.services.ParserService], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.camel.spi.ComponentResolver], bundle: org.apache.camel.camel-core [3], symbolicName: org.apache.camel.camel-core
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.blueprint.container.BlueprintContainer], bundle: org.apache.camel.camel-blueprint [2], symbolicName: org.apache.camel.camel-blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.startlevel.StartLevel], bundle: de.kalpatec.pojosr.framework [0], symbolicName: de.kalpatec.pojosr.framework
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.camel.spi.ComponentResolver], bundle: org.apache.camel.camel-sql [6], symbolicName: org.apache.camel.camel-sql
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.camel.spi.LanguageResolver], bundle: org.apache.camel.camel-core [3], symbolicName: org.apache.camel.camel-core
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.aries.blueprint.NamespaceHandler], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.packageadmin.PackageAdmin], bundle: de.kalpatec.pojosr.framework [0], symbolicName: de.kalpatec.pojosr.framework
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.camel.spi.TypeConverterLoader], bundle: de.kalpatec.pojosr.framework [0], symbolicName: de.kalpatec.pojosr.framework
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.apache.camel.spi.DataFormatResolver], bundle: org.apache.camel.camel-core [3], symbolicName: org.apache.camel.camel-core
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.service.blueprint.container.BlueprintContainer], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           WARN  ServiceReference: [org.osgi.framework.hooks.bundle.EventHook], bundle: org.apache.aries.blueprint [17], symbolicName: org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] BlueprintExtender              INFO  Destroying BlueprintContainer for bundle org.apache.aries.blueprint
      [mel.test.blueprint.Main.main()] BlueprintExtender              INFO  Destroying BlueprintContainer for bundle org.apache.camel.camel-blueprint
      [mel.test.blueprint.Main.main()] Activator                      INFO  Camel activator stopping
      [mel.test.blueprint.Main.main()] Activator                      INFO  Camel activator stopped
      [mel.test.blueprint.Main.main()] CamelBlueprintHelper           INFO  Deleting work directory target/bundles/1417682923424
      [ERROR] *************************************
      [ERROR] Error occurred while running main from: org.apache.camel.test.blueprint.Main
      [ERROR] 
      java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:483)
      	at org.apache.camel.maven.RunMojo$1.run(RunMojo.java:488)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.RuntimeException: Gave up waiting for service (objectClass=org.apache.camel.CamelContext)
      	at org.apache.camel.test.blueprint.CamelBlueprintHelper.getOsgiService(CamelBlueprintHelper.java:240)
      	at org.apache.camel.test.blueprint.CamelBlueprintHelper.getOsgiService(CamelBlueprintHelper.java:202)
      	at org.apache.camel.test.blueprint.Main.doStart(Main.java:104)
      	at org.apache.camel.support.ServiceSupport.start(ServiceSupport.java:61)
      	at org.apache.camel.main.MainSupport.run(MainSupport.java:149)
      	at org.apache.camel.main.MainSupport.run(MainSupport.java:353)
      	at org.apache.camel.test.blueprint.Main.main(Main.java:81)
      	... 6 more
      [ERROR] *************************************
      

        Issue Links

          Activity

          njiang Willem Jiang added a comment -

          Hi Charles,

          I just run the mvn camel:run inside of camel-example-sql-blueprint, I cannot reproduce the error that you hit.
          Can you run "mvn clean install -Dtest=false" to build the Camel-2.15-SNAPSHOT first?

          Regards,

          Willem

          cmoulliard Charles Moulliard added a comment -

          Issue not longer there after doing a mvn clean install of camel-2.15-SNAPSHOT project


            People

            • Assignee:
              cmoulliard Charles Moulliard
              Reporter:
              cmoulliard Charles Moulliard
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development