Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-7383

camel-script-* features should depend on scripting-api bundle

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.13.0
    • Fix Version/s: 2.12.4, 2.13.1, 2.14.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      camel-script-* features use package javax.script which may be not exported by system bundle.
      camel-script-* feature should depend on ServiceMix's scripting bundle just like camel-groovy.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ggrzybek Grzegorz Grzybek
                Reporter:
                ggrzybek Grzegorz Grzybek
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: