Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-6615

Upgrade to XML-Security 1.5.5 + enable secureValidation

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.10.7, 2.11.2, 2.12.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description


      This task is to upgrade the Apache Santuario (XML Security for Java) dependency from 1.5.1 -> 1.5.5. Also, to enable "secureValidation" by default for the decryption process, which gives automatic protection against some attacks.

        Attachments

        1. camel-6615.patch
          1 kB
          Colm O hEigeartaigh

          Activity

            People

            • Assignee:
              hadrian Hadrian Zbarcea
              Reporter:
              coheigea Colm O hEigeartaigh
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: