Camel
  1. Camel
  2. CAMEL-6103

camel-fop - Allow to load configuration file from classpath

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.10.0
    • Fix Version/s: 2.12.0
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Novice

      Description

      See
      http://stackoverflow.com/questions/15085952/apache-camel-fop-component-config-file-location

      The option userConfigURL should be loaded using the ResourceHelper API from camel-core in the util package. It allows to load the resource from classpath, file, http, etc just as we do with camel-velocity, xslt, and other components as well.

        Activity

        Claus Ibsen made changes -
        Field Original Value New Value
        Resolution Duplicate [ 3 ]
        Fix Version/s Future [ 12315692 ]
        Fix Version/s 2.12.0 [ 12323968 ]
        Assignee Claus Ibsen [ davsclaus ]
        Status Open [ 1 ] Resolved [ 5 ]
        Claus Ibsen added a comment -

        Yeah its a duplicate of CAMEL-6666 - what a great number

        Carsten Ringe added a comment -

        FopEndpoint already uses ResourceHelper#resolveMandatoryResourceAsInputStream (class FopEndpoint, line 82). Maybe this is resolved?

        Claus Ibsen created issue -

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development