Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.4, 2.9.0
    • Fix Version/s: 2.10.0
    • Component/s: camel-core
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Estimated Complexity:
      Unknown

      Description

      Current MDC support in camel uses different property names. My proposal is to align them and use a "camel." prefix for all of them to let them live in own logical namespace:

      Before change After change
      breadcrumbId camel.breadcrumbId
      exchangeId camel.exchangeId
      messageId camel.messageId
      correlationId camel.correlationId
      routeId camel.routeId
      camelContextId camel.contextId
      transactionKey camel.transactionKey

        Attachments

        1. CAMEL-5047-log4j.diff
          7 kB
          Łukasz Dywicki
        2. CAMEL-5047.diff
          4 kB
          Łukasz Dywicki

          Activity

            People

            • Assignee:
              davsclaus Claus Ibsen
              Reporter:
              splatch Łukasz Dywicki
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: