Camel
  1. Camel
  2. CAMEL-4671

The camel-core feature should not reference jaxb2 api / impl

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.8.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      Those are supposed to be provided by the JRE and deploying those cause problems when the osgi does not hide those packages.

        Activity

        Hide
        Guillaume Nodet added a comment -

        There are two cases here.
        When deploying in Karaf using a default JRE 1.6 profile, jaxb2 spec and impl are provided by the JRE and thus not required.
        When deploying on a JRE 1.5 profile (even using a 1.6 JRE, i.e. hiding the new packages), those will have to be deployed by the user.
        A possible alternative would be to create two different features, but I don't really think it's necessary.

        Show
        Guillaume Nodet added a comment - There are two cases here. When deploying in Karaf using a default JRE 1.6 profile, jaxb2 spec and impl are provided by the JRE and thus not required. When deploying on a JRE 1.5 profile (even using a 1.6 JRE, i.e. hiding the new packages), those will have to be deployed by the user. A possible alternative would be to create two different features, but I don't really think it's necessary.
        Hide
        Willem Jiang added a comment -

        This patch is revert in Camel 2.8.4 to maintain the backward compatibility of Camel 2.8.x
        http://svn.apache.org/viewvc?rev=1222332&view=rev
        http://svn.apache.org/viewvc?rev=1222435&view=rev

        Show
        Willem Jiang added a comment - This patch is revert in Camel 2.8.4 to maintain the backward compatibility of Camel 2.8.x http://svn.apache.org/viewvc?rev=1222332&view=rev http://svn.apache.org/viewvc?rev=1222435&view=rev
        Hide
        Jean-Baptiste Onofré added a comment -

        Even using a JRE 1.6 profiles (with Karaf 2.2.4), the JAXB bundles are required (version mismatch).

        Show
        Jean-Baptiste Onofré added a comment - Even using a JRE 1.6 profiles (with Karaf 2.2.4), the JAXB bundles are required (version mismatch).
        Hide
        Daniel Kulp added a comment -


        This change is causing issues with several components. We're looking for better solutions that can be provided by future versions of Karaf.

        Show
        Daniel Kulp added a comment - This change is causing issues with several components. We're looking for better solutions that can be provided by future versions of Karaf.
        Hide
        Claus Ibsen added a comment -

        Yeah for now lets avoid this change in the 2.x timeline, as it causes problems.

        Show
        Claus Ibsen added a comment - Yeah for now lets avoid this change in the 2.x timeline, as it causes problems.

          People

          • Assignee:
            Guillaume Nodet
            Reporter:
            Guillaume Nodet
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development