Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-18963

Support latest version of OpenAPI Specification in Camel openapi components

    XMLWordPrintableJSON

Details

    • Unknown

    Description

      The apicurio library used in the openapi components only supports 3.0.2 but OAS 3.1.0 was released in February 2021.
      The swagger.io.v3 library already supports 3.1.0 so we could switch to using that instead as it seems to be more actively maintained.
      The apicurio issue related to supporting 3.1.0 was last updated over a year ago.

      Attachments

        Issue Links

          There are no Sub-Tasks for this issue.

          Activity

            People

              klease78 Karen Lease
              klease78 Karen Lease
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: