Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-15705

camel 2.x - camel-chronicle feature install failed due to xstream-java8 version

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.25.2
    • Fix Version/s: 2.25.3
    • Component/s: osgi
    • Labels:
      None
    • Environment:

      Java 8

    • Estimated Complexity:
      Unknown

      Description

      Start karaf 4.2.9 OSGi container, execute:

      karaf@root()> feature:repo-add camel 2.25.2
      karaf@root()> feature:install camel-chronicle

      Caused by: java.io.IOException: Error resolving artifact org.apache.servicemix.bundles:org.apache.servicemix.bundles.xstream-java8:jar:1.4.11.1_1: [Could not find artifact org.apache.servicemix.bundles:org.apache.servicemix.bundles.xstream-java8:jar:1.4.11.1_1 in central (https://repo1.maven.org/maven2/)]
      

      The bundle "xstream-java8" has to be corrected to "xstream".

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                xldai Xilai Dai
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: