Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-14726

Upgrade MongoDB client to 4.0.0

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.0
    • Component/s: camel-mongodb
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      There's a 4.x version of the Mongo Java drivers available. Some projects (like Quarkus) are already proposing to upgrade. It'd be good if Camel can do likewise.

      Initially, to minimise the effort required to upgrade, I was planning to use mongodb-driver-legacy.

      Eventually it'd be good to remove dependencies on legacy APIs as mentioned in CAMEL-14423.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jamesnetherton James Netherton
                Reporter:
                jamesnetherton James Netherton
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m