Uploaded image for project: 'Camel'
  1. Camel
  2. CAMEL-11029

karaf - camel-cdi won't install

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.16.4, 2.16.5, 2.18.2, 2.18.3
    • Fix Version/s: None
    • Component/s: camel-cdi
    • Labels:
      None
    • Environment:

      Verified in ServiceMix 7.0.0/Karaf 4.0.8 with Oracle Java 8

    • Estimated Complexity:
      Unknown

      Description

      Attempting to install camel-cdi feature results in an error. I first installed pax-cdi and pax-cdi-weld features, which installed fine, but attempting to install camel-cdi results in a failure:

      admin@root>feature:install camel-cdi
      Error executing command: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=camel-cdi; type=karaf.feature; version="[2.16.4,2.16.4]"; filter:="(&(osgi.identity=camel-cdi)(type=karaf.feature)(version>=2.16.4)(version<=2.16.4))" [caused by: Unable to resolve camel-cdi/2.16.4: missing requirement [camel-cdi/2.16.4] osgi.identity; osgi.identity=org.apache.camel.camel-cdi; type=osgi.bundle; version="[2.16.4,2.16.4]"; resolution:=mandatory [caused by: Unable to resolve org.apache.camel.camel-cdi/2.16.4: missing requirement [org.apache.camel.camel-cdi/2.16.4] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.deltaspike.core.util.metadata.builder)(version>=1.5.0)(!(version>=2.0.0)))"]]
      

      The pax-cdi features are specifying version 1.3.0 (for RC1) or 1.4.2 (for RC2), but camel-cdi is looking for version 1.5 and above.

      I was able to get camel-cdi installed by first installing a newer version of deltaspike than the one referenced by pax-cdi:

      install mvn:org.apache.deltaspike.core/deltaspike-core-api/1.5.4
      install mvn:org.apache.deltaspike.core/deltaspike-core-impl/1.5.4
      feature:install camel-cdi
      

      This also brings in pax-cdi 1.0.0.RC1. However, my test bundle (based on camel-example-cdi-osgi) fails due to a problem with pax-cdi 1.0.0.RC1.

      I am able to install and run my bundle just fine fine, when staring a scratch ServiceMix installation, by overriding the pax-cdi and deltaspike using the script:

      feature:repo-add mvn:org.ops4j.pax.cdi/pax-cdi-features/1.0.0.RC2/xml/features
      install mvn:org.apache.deltaspike.core/deltaspike-core-api/1.7.2
      install mvn:org.apache.deltaspike.core/deltaspike-core-impl/1.7.2
      feature:install pax-cdi/1.0.0.RC2
      feature:install pax-cdi-weld/1.0.0.RC2
      feature:install camel-cdi
      install -s mvn:com.omniprise.demo/camel-osgi-cdi/0.0.1-SNAPSHOT
      

      I have also verified this on Camel 2.18.2 using Karaf 4.0.8 and the script:

      feature:repo-add mvn:org.apache.camel.karaf/apache-camel/2.18.2/xml/features
      feature:repo-add mvn:org.ops4j.pax.cdi/pax-cdi-features/1.0.0.RC2/xml/features
      install mvn:org.apache.deltaspike.core/deltaspike-core-api/1.7.2
      install mvn:org.apache.deltaspike.core/deltaspike-core-impl/1.7.2
      feature:install pax-cdi/1.0.0.RC2
      feature:install pax-cdi-weld/1.0.0.RC2
      feature:install camel/2.18.2
      feature:install camel-blueprint/2.18.2
      feature:install camel-cdi/2.18.2
      install -s mvn:com.omniprise.demo/camel-osgi-cdi/0.0.1-SNAPSHOT
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              bob.blackard Bob Blackard

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment