Looks good. A few minor things:
1. Rename "isRequireOver" method and "requireOver" field to "requiresOver" to be consistent with "requiresOrder".
2. I like the approach of having these properties be boolean fields. Please move the SqlRankFunction.requiresOrder field up to SqlAggFunction and add a constructor parameter. You should be able to remove requiresOrder() methods in sub-classes.
3. Mark as "Deprecated // to be removed before 2.0" all but one constructor of SqlAggFunction. Fix existing code that uses deprecated constructors.