Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0-incubating
    • Component/s: None
    • Labels:
      None

      Description

      Downgrade to guava-11.0.2. First, change pom.xml to

          <dependency>
            <groupId>com.google.guava</groupId>
            <artifactId>guava</artifactId>
            <!-- We support versions as old as 11.0.2 (the version used by                                                                                                                                                                                                                                                                                                        
                 Hadoop) but prefer more recent versions. -->
            <version>11.0.2</version>
          </dependency>
      

      Next, fix compile errors:

      • The class FluentIterable was introduced in guava-12.0. Optiq uses guava-11.0.2 (because of Hive and Hadoop).
      • In 11.0.2 ImmutableSortedMap only implements SortedMap, but we rely on it implementing NavigableMap (not until 12).
      • Similarly ImmutableSortedSet.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                julianhyde Julian Hyde
                Reporter:
                julianhyde Julian Hyde
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: