Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-3025

Upgrade to Go 1.12

    XMLWordPrintableJSON

    Details

      Description

      Upgrade to Go 1.12 and remove the DualStack setting from net.Dialer as it is now deprecated.

      Go 1.10 should be removed from Travis as the Go team supports the current release and the last release.

      Update the travis config to test with the dependencies managed using dep in Go 1.12.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                francischuang Francis Chuang
                Reporter:
                francischuang Francis Chuang
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m