Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-2237

JDK 10 builds fail with NPE due to SUREFIRE-1439

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.17.0
    • Fix Version/s: 1.17.0
    • Component/s: None
    • Labels:
      None

      Description

      SUREFIRE-1439 causes an NPE when using JDK 10. CALCITE-2225 upgraded to Apache parent pom 19 which included Surefire 2.20.1. MPOM-184 is tracking the fix for Apache parent pom 20. We should update to Surefire 2.21.0 to ensure that builds function on JDK 10.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                risdenk Kevin Risden
                Reporter:
                risdenk Kevin Risden
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: