Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-2191

Drop support for Guava versions earlier than 19

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.16.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently, Calcite-1.15.0 version supports Guava versions from 23 to 14.

      Calcite-1.16.0-Snapshot is building against version 19.0.1 

      As far I know the only reason we support versions earlier to 19 is Hive project depending on Guava 14.0.1 This is not true anymore after https://issues.apache.org/jira/browse/HIVE-15393.

      Druid project is still using Guava 16.0.1 but some work is under review to make sure it is not using deprecated API.   

      Thus I think it is time to Drop support for versions earlier than 19

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                julianhyde Julian Hyde
                Reporter:
                bslim slim bouguerra
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: