Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-2005

Core project failed during default-test on Windows

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.14.0
    • Fix Version/s: 1.15.0
    • Component/s: core
    • Labels:
      None
    • Environment:

      java version "1.8.0_144",
      maven version "3.5.0", windows

      Description

      The following failure is generated when running "mvn clean install"

      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] Calcite ............................................ SUCCESS [  2.728 s]
      [INFO] Calcite Linq4j ..................................... SUCCESS [ 13.181 s]
      [INFO] Calcite Core ....................................... FAILURE [03:31 min]
      [INFO] Calcite Cassandra .................................. SKIPPED
      [INFO] Calcite Druid ...................................... SKIPPED
      [INFO] Calcite Elasticsearch .............................. SKIPPED
      [INFO] Calcite Elasticsearch5 ............................. SKIPPED
      [INFO] Calcite Examples ................................... SKIPPED
      [INFO] Calcite Example CSV ................................ SKIPPED
      [INFO] Calcite Example Function ........................... SKIPPED
      [INFO] Calcite File ....................................... SKIPPED
      [INFO] Calcite MongoDB .................................... SKIPPED
      [INFO] Calcite Pig ........................................ SKIPPED
      [INFO] Calcite Piglet ..................................... SKIPPED
      [INFO] Calcite Plus ....................................... SKIPPED
      [INFO] Calcite Spark ...................................... SKIPPED
      [INFO] Calcite Splunk ..................................... SKIPPED
      [INFO] Calcite Ubenchmark ................................. SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 03:47 min
      [INFO] Finished at: 2017-10-09T14:10:17+03:00
      [INFO] Final Memory: 72M/1649M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test (default-test) on project calcite-core: There are test failures.
      [ERROR]
      [ERROR] Please refer to D:\Project\git\calcite\core\target\surefire-reports for the individual test results.
      [ERROR] -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test (default-test) on project calcite-core: There are test failures.
      
      Please refer to D:\Project\git\calcite\core\target\surefire-reports for the individual test results.
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213)
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:154)
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:146)
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:117)
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:81)
              at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
              at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:309)
              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:194)
              at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:107)
              at org.apache.maven.cli.MavenCli.execute(MavenCli.java:993)
              at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:345)
              at org.apache.maven.cli.MavenCli.main(MavenCli.java:191)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.lang.reflect.Method.invoke(Method.java:498)
              at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
              at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
              at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
              at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      Caused by: org.apache.maven.plugin.MojoFailureException: There are test failures.
      
      Please refer to D:\Project\git\calcite\core\target\surefire-reports for the individual test results.
              at org.apache.maven.plugin.surefire.SurefireHelper.reportExecution(SurefireHelper.java:91)
              at org.apache.maven.plugin.surefire.SurefirePlugin.handleSummary(SurefirePlugin.java:320)
              at org.apache.maven.plugin.surefire.AbstractSurefireMojo.executeAfterPreconditionsChecked(AbstractSurefireMojo.java:892)
              at org.apache.maven.plugin.surefire.AbstractSurefireMojo.execute(AbstractSurefireMojo.java:755)
              at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
              ... 20 more
      [ERROR]
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
      [ERROR]
      [ERROR] After correcting the problems, you can resume the build with the command
      [ERROR]   mvn <goals> -rf :calcite-core
      

        Activity

        julianhyde Julian Hyde added a comment -

        Resolved in release 1.15.0 (2017-12-11).

        julianhyde Julian Hyde added a comment -

        Fixed in 9bb54006.

        julianhyde Julian Hyde added a comment -

        I've now tried on Windows, and am seeing the same results with maven-3.2.5 and maven-3.5.0. The failure of UtilTest.testXmlOutput (due to linefeed differences) was introduced in the fix to CALCITE-1988, i.e. after 1.14.0. I have also seen an occasional failure of StreamTest.testStreamCancel.

        Both test failures can be safely ignored.

        julianhyde Julian Hyde added a comment -

        I thought that maven-3.5 might be the cause (I've only tried 3.3 before) but I just checked, and calcite builds fine on maven-3.5.0.

        I'll try building on windows as soon as I have access to a windows instance.

        Is that that full log you have posted above? I can see that it failed because of test failures, but I can't see which tests failed. Usually maven prints that detail to stdout.


          People

          • Assignee:
            julianhyde Julian Hyde
            Reporter:
            dmitry.shmushkis Dmitry Shmushkis
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development