Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1815

Change Avatica dependency of the Pig adapter to avatica-core

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.12.0
    • Fix Version/s: 1.14.0
    • Component/s: pig-adapter
    • Labels:
      None

      Description

      Calcite-pig unnecessarily depends on the full avatica instead of avatica-core. This causes problems in some environments because avatica jar contains slf4j classes.

        Issue Links

          Activity

          michaelmior Michael Mior added a comment -

          Resolved in release 1.14.0 (2017-10-01)

          jcamachorodriguez Jesus Camacho Rodriguez added a comment -

          Sure Eli Levine, will do, thanks for letting me know.

          elilevine Eli Levine added a comment -

          Jesus Camacho Rodriguez, I'm traveling at the moment and won't be able to address the comments in time for 1.13. Let's push this one out to the next release.

          jcamachorodriguez Jesus Camacho Rodriguez added a comment -

          Eli Levine, could you address latest Josh Elser comments in the PR? We are still on time to include this in 1.13, I plan to cut the first RC tomorrow/Wednesday. Thanks

          julianhyde Julian Hyde added a comment -

          Josh Elser, Can you please review this change? I am inclined to accept, as I see from reading CALCITE-1694 that we were in two minds about using shaded Avatica.

          elilevine Eli Levine added a comment -

          Oh interesting. The reason for this PR is the fact that the full avatica jar bundles unshaded slf4j classes, which causes class clashes if a project depends on both calcite-pig (which depends on avatica) and slf4j. I am hitting this at Salesforce now.

          I did run all calcite-pig tests and did not get any errors reported by CALCITE-1694.

          julianhyde Julian Hyde added a comment -

          Eli Levine, This change basically undoes CALCITE-1694. Can you explain why the causes of that issue are no longer valid?

          julianhyde Julian Hyde added a comment -

          Reviewing now.

          elilevine Eli Levine added a comment -

            People

            • Assignee:
              elilevine Eli Levine
              Reporter:
              elilevine Eli Levine
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development