Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1402

Druid Filter translation incorrect if input reference is in RHS of comparison

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.0
    • Fix Version/s: 1.10.0
    • Component/s: druid
    • Labels:
      None

      Description

      It should have been fixed as part of CALCITE-1357/CALCITE-1358.

        Activity

        jcamachorodriguez Jesus Camacho Rodriguez added a comment -

        Julian Hyde, I have created https://github.com/apache/calcite/pull/290 . Could you take a look?

        Thanks

        julianhyde Julian Hyde added a comment -

        +1

        Jesus Camacho Rodriguez, There is a test failure after I rebased (I think caused by CALCITE-1392) that you will need to fix before committing.

        jcamachorodriguez Jesus Camacho Rodriguez added a comment -

        Thanks! Yes, the test that I added, I was doing that right now.

        jcamachorodriguez Jesus Camacho Rodriguez added a comment -

        Fixed in http://git-wip-us.apache.org/repos/asf/calcite/commit/55ecc70 (including the test). Thanks for reviewing Julian Hyde

        jcamachorodriguez Jesus Camacho Rodriguez added a comment -

        Resolved in release 1.10.0 (2016-10-12).


          People

          • Assignee:
            jcamachorodriguez Jesus Camacho Rodriguez
            Reporter:
            jcamachorodriguez Jesus Camacho Rodriguez
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development