Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1394

Using CoreMatchers.containsString causes javadoc errors

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: avatica-1.9.0, 1.10.0
    • Component/s: None
    • Labels:
      None

      Description

      Under JDK 1.7, using the method CoreMatchers.containsString causes javadoc warnings, similar to https://github.com/junit-team/junit4/issues/872. The cause, I think, is that Avatica uses mockito and it bundles a different version of hamcrest. The solution is to use StringContains.containsString, which exists in an earlier version of hamcrest.

        Activity

        julianhyde Julian Hyde added a comment -

        In fact, mockito are now saying that mockito-all is a bad idea: https://github.com/mockito/mockito/issues/324. We should get rid of mockito-all.

        julianhyde Julian Hyde added a comment -

        Fixed in http://git-wip-us.apache.org/repos/asf/calcite/commit/514d262e. (The peculiar fix version is because the commit contains a mixture of Calcite and Avatica changes. That's not usually OK, but these are just issues with the QA/release process, not functionality.)

        jcamachorodriguez Jesus Camacho Rodriguez added a comment -

        Resolved in release 1.10.0 (2016-10-12).


          People

          • Assignee:
            julianhyde Julian Hyde
            Reporter:
            julianhyde Julian Hyde
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development