Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1370

In SqlKind, add OTHER_DDL to DDL enum set

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.9.0
    • Component/s: core
    • Labels:
      None

      Description

      We need to add OTHER_DDL enum value in SqlKind to DDL enum set to execute DDL queries implemented as OTHER_DDL type. Otherwise we are not executing ddl queries implemented as OTHER_DDL; instead we are going to validate the identifiers used in DDL query to from catalog table and fail with below exceptions

      java.sql.SQLException: Error while executing SQL "create function myreverse(VARCHAR) returns VARCHAR as 'org.apache.phoenix.end2end.MyReverse' using jar 'hdfs://localhost:51573/hbase/tmpjars/myjar1.jar'": From line 1, column 17 to line 1, column 25: Column 'MYREVERSE' not found in any table
      	at org.apache.calcite.avatica.Helper.createException(Helper.java:56)
      	at org.apache.calcite.avatica.Helper.createException(Helper.java:41)
      	at org.apache.calcite.avatica.AvaticaStatement.executeInternal(AvaticaStatement.java:147)
      	at org.apache.calcite.avatica.AvaticaStatement.execute(AvaticaStatement.java:199)
      	at org.apache.phoenix.calcite.BaseCalciteIT$Sql.execute(BaseCalciteIT.java:179)
      	at org.apache.phoenix.calcite.CalciteDDLIT.testCreateFunction(CalciteDDLIT.java:57)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:497)
      	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
      	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
      	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
      	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
      	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
      	at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:325)
      	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:78)
      	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:57)
      	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:290)
      	at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:71)
      	at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:288)
      	at org.junit.runners.ParentRunner.access$000(ParentRunner.java:58)
      	at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:268)
      	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:26)
      	at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
      	at org.junit.rules.ExternalResource$1.evaluate(ExternalResource.java:48)
      	at org.junit.rules.RunRules.evaluate(RunRules.java:20)
      	at org.junit.runners.ParentRunner.run(ParentRunner.java:363)
      	at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
      	at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
      	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:459)
      	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:675)
      	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382)
      	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:192)
      Caused by: org.apache.calcite.runtime.CalciteContextException: From line 1, column 17 to line 1, column 25: Column 'MYREVERSE' not found in any table
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:422)
      	at org.apache.calcite.runtime.Resources$ExInstWithCause.ex(Resources.java:405)
      	at org.apache.calcite.sql.SqlUtil.newContextException(SqlUtil.java:799)
      	at org.apache.calcite.sql.SqlUtil.newContextException(SqlUtil.java:784)
      	at org.apache.calcite.sql.validate.SqlValidatorImpl.newValidationError(SqlValidatorImpl.java:4049)
      	at org.apache.calcite.sql.validate.EmptyScope.findQualifyingTableName(EmptyScope.java:108)
      	at org.apache.calcite.sql.validate.DelegatingScope.findQualifyingTableName(DelegatingScope.java:113)
      	at org.apache.calcite.sql.validate.DelegatingScope.fullyQualify(DelegatingScope.java:156)
      	at org.apache.calcite.sql.validate.SqlValidatorImpl.validateIdentifier(SqlValidatorImpl.java:2647)
      	at org.apache.calcite.sql.SqlIdentifier.validateExpr(SqlIdentifier.java:288)
      	at org.apache.calcite.sql.SqlOperator.validateCall(SqlOperator.java:406)
      	at org.apache.calcite.sql.validate.SqlValidatorImpl.validateCall(SqlValidatorImpl.java:4202)
      	at org.apache.calcite.sql.SqlCall.validate(SqlCall.java:112)
      	at org.apache.calcite.sql.validate.SqlValidatorImpl.validateScopedExpression(SqlValidatorImpl.java:827)
      	at org.apache.calcite.sql.validate.SqlValidatorImpl.validate(SqlValidatorImpl.java:543)
      	at org.apache.calcite.sql2rel.SqlToRelConverter.convertQuery(SqlToRelConverter.java:551)
      	at org.apache.calcite.prepare.Prepare.prepareSql(Prepare.java:229)
      	at org.apache.calcite.prepare.Prepare.prepareSql(Prepare.java:193)
      	at org.apache.calcite.prepare.CalcitePrepareImpl.prepare2_(CalcitePrepareImpl.java:733)
      	at org.apache.calcite.prepare.CalcitePrepareImpl.prepare_(CalcitePrepareImpl.java:597)
      	at org.apache.calcite.prepare.CalcitePrepareImpl.prepareSql(CalcitePrepareImpl.java:567)
      	at org.apache.calcite.jdbc.CalciteConnectionImpl.parseQuery(CalciteConnectionImpl.java:215)
      	at org.apache.calcite.jdbc.CalciteMetaImpl.prepareAndExecute(CalciteMetaImpl.java:594)
      	at org.apache.calcite.avatica.AvaticaConnection.prepareAndExecuteInternal(AvaticaConnection.java:613)
      	at org.apache.calcite.avatica.AvaticaStatement.executeInternal(AvaticaStatement.java:139)
      	... 31 more
      Caused by: org.apache.calcite.sql.validate.SqlValidatorException: Column 'MYREVERSE' not found in any table
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:422)
      	at org.apache.calcite.runtime.Resources$ExInstWithCause.ex(Resources.java:405)
      	at org.apache.calcite.runtime.Resources$ExInst.ex(Resources.java:514)
      	... 54 more
      
      1. CALCITE-1370.patch
        0.6 kB
        Rajeshbabu Chintaguntla

        Activity

        rajeshbabu Rajeshbabu Chintaguntla added a comment -

        Here is the simple patch.
        Please review Julian HydeMaryann Xue.

        julianhyde Julian Hyde added a comment - - edited

        I am wondering what we can do to prevent this from happening again. I think tests in SqlParserTest (and Phoenix's sub-class of that test) should make sure that the tree is DDL, e.g.

        void testInsert() {
          sql("insert into foo values (1)")
            .node(not(isDdl()));
        }
        

        What do you think?

        julianhyde Julian Hyde added a comment -

        Fixed in http://git-wip-us.apache.org/repos/asf/calcite/commit/547aa67c. Thanks for the patch, Rajeshbabu Chintaguntla!

        I also added SET_OPTION as DDL, and added some parser tests. I suggest that you use isDdl() in parser-extension tests such as those in Phoenix.

        rajeshbabu Rajeshbabu Chintaguntla added a comment -

        Julian Hyde
        Thanks for adding the tests and committing. Sure will make use of it in Phoenix too.

        jcamachorodriguez Jesus Camacho Rodriguez added a comment -

        Resolved in release 1.9.0 (2016-09-22)


          People

          • Assignee:
            julianhyde Julian Hyde
            Reporter:
            rajeshbabu Rajeshbabu Chintaguntla
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development