Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1279

Druid "select" query gives ClassCastException

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.8.0
    • Component/s: None
    • Labels:
      None

      Description

      In the Druid adapter, a query of "select" query type gives ClassCastException. This does not apply to other query types, such as "groupBy", so only SQL queries that have no aggregation (GROUP BY, HAVING) are affected.

      The cause is that the DRUID_FETCH property recently changed from STRING to NUMBER but we are still accessing it using getString().

        Issue Links

          Activity

          julianhyde Julian Hyde added a comment -

          Resolved in release 1.8.0 (2016-06-13).


            People

            • Assignee:
              julianhyde Julian Hyde
              Reporter:
              julianhyde Julian Hyde
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development