Uploaded image for project: 'Calcite'
  1. Calcite
  2. CALCITE-1202

Lock version of Jekyll used by website

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.8.0, avatica-1.8.0
    • Component/s: None
    • Labels:
      None

      Description

      I had a newer version of Jekyll installed for other projects and realized that this was causing a significant amount of changes in the generated HTML.

      We should lock jekyll-2.4.0 as the version we want to use in the Gemfile. This will prevent unintended changes to HTML due to the installed version of Jekyll being potentially different across different developer machines. Presently, this is being set by the github-pages gem implicitly.

        Activity

        julianhyde Julian Hyde added a comment - - edited

        Thanks – I had noticed this issue also.

        Another issue I am working on with the website is the whitespace that is caused by pages that do for i in list do if predicate( i ) ... end if end for, where "list" is the set of committer, or the set of news items. Due to the way jekyll generates web pages, if an item i is added to the list, the page will get some extra whitespace and if predicate( i ) is false. I've made some progress recently by changing the jekyll templates.

        elserj Josh Elser added a comment -

        Ah, I was wondering where all of that came from!

        julianhyde Julian Hyde added a comment -

        Resolved in release 1.8.0 (2016-06-13).


          People

          • Assignee:
            elserj Josh Elser
            Reporter:
            elserj Josh Elser
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development