Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Component/s: Ant Integration
    • Labels:
      None

      Description

      Vincent/Magnus,

      Now that Cactus uses Cargo, it requires JDK 1.4. I got the following exception while running a test using JDK 1.3 and Cactus from CVS:

      File...... C:\Documents and Settings\bianconi\.maven\cache\cactus-maven-1.8dev-custom\plugin.jelly
      Element... ant:taskdef
      Line...... 109
      Column.... 75
      org/codehaus/cargo/module/webapp/WarArchive (Unsupported major.minor version 48.0)
      Total time: 55 seconds
      Finished at: Wed Jun 08 12:33:13 GMT 2005

      Looking at Cargo's page (http://cargo.codehaus.org/Installation), it says Cargo indeed depends on JDK 1.4.

      So, I'm fine with the change, but if we do so, we need to update the documentation (and maybe refactor some code to take advantage of 1.4 capabilities).

      – Felipe

        Activity

        Hide
        Vincent Massol added a comment -

        Yes you're right. I wasn't even aware that Cactus was still working with JDK 1.3...

        I'm all for using JDK 1.4 for Cactus 1.8 and above.

        Thanks for pointing this out!

        Show
        Vincent Massol added a comment - Yes you're right. I wasn't even aware that Cactus was still working with JDK 1.3... I'm all for using JDK 1.4 for Cactus 1.8 and above. Thanks for pointing this out!

          People

          • Assignee:
            Felipe Leme
            Reporter:
            Felipe Leme
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development