Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 1.4.5
    • Fix Version/s: 1.4.7
    • Component/s: None
    • Labels:
      None
    • Environment:
      Window 7 64 bit

      Description

      The install documentation says to "Be sure to install Ruby 1.8.6", but after installing that and running "gem update --system", that will give you an error saying it needs to have Ruby 1.8.7. After installing 1.8.7, doing the "gem update --system", installing buildr, and trying any command with "buildr" (i.e. "buildr --version", "buildr --help", "buildr") it give the following error:

      C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:926:in `report_activate_error': RubyGem version error: buildr(1.4.5 not >= 0) (Gem::LoadError)
      from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:244:in `activate_dep'
      from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:236:in `activate'
      from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:1307:in `gem'
      from C:/Ruby187/bin/buildr:18

      C:\>gem list

          • LOCAL GEMS ***

      atoulme-Antwrap (0.7.1)
      builder (2.1.2)
      buildr (1.4.5 x86-mswin32)
      diff-lcs (1.1.2)
      highline (1.5.1)
      hoe (2.3.3)
      json_pure (1.4.3)
      minitar (0.5.3)
      net-sftp (2.0.4)
      net-ssh (2.0.23)
      rake (0.8.7)
      rjb (1.3.2 x86-mswin32-60)
      rspec (2.1.0)
      rspec-core (2.1.0)
      rspec-expectations (2.1.0)
      rspec-mocks (2.1.0)
      rubyforge (2.0.3)
      rubygems-update (1.7.2)
      rubyzip (0.9.4)
      xml-simple (1.0.12)

        Activity

        Jesse Tomlinson created issue -
        Hide
        Ilya Pyatigorskiy added a comment -

        i have exactly the same problem
        quick google shows that this could be related to the "mswin32" part and could be a general problem (i.e. not buildr related):
        http://stackoverflow.com/questions/5373675/rails-problem-sqlite3-gem-not-being-seen
        http://stackoverflow.com/questions/5444472/problem-requiring-the-rmagick-gem-with-ruby

        Show
        Ilya Pyatigorskiy added a comment - i have exactly the same problem quick google shows that this could be related to the "mswin32" part and could be a general problem (i.e. not buildr related): http://stackoverflow.com/questions/5373675/rails-problem-sqlite3-gem-not-being-seen http://stackoverflow.com/questions/5444472/problem-requiring-the-rmagick-gem-with-ruby
        Hide
        Ilya Pyatigorskiy added a comment -

        ok, a simple workaround: don't do "gem update --system" - then 1.8.7 works for buildr/windows

        Show
        Ilya Pyatigorskiy added a comment - ok, a simple workaround: don't do "gem update --system" - then 1.8.7 works for buildr/windows
        Hide
        Ilya Pyatigorskiy added a comment -

        one more thing to notice (completely unrelated tho): rjb requires msvcr71 - see this blog post for instructions: http://i.justrealized.com/2009/how-to-fix-missing-msvcr71dll-problem-in-windows/

        Show
        Ilya Pyatigorskiy added a comment - one more thing to notice (completely unrelated tho): rjb requires msvcr71 - see this blog post for instructions: http://i.justrealized.com/2009/how-to-fix-missing-msvcr71dll-problem-in-windows/
        Hide
        Jesse Tomlinson added a comment -

        @Ilya thanks for the simple work around. So far, it looks like that's helping a lot.

        Show
        Jesse Tomlinson added a comment - @Ilya thanks for the simple work around. So far, it looks like that's helping a lot.
        Alex Boisvert made changes -
        Field Original Value New Value
        Fix Version/s 1.4.7 [ 12317053 ]
        Fix Version/s 1.4.6 [ 12316295 ]
        Hide
        Antoine Toulme added a comment -

        I removed the "gem update --system" line from the Windows instructions.

        Show
        Antoine Toulme added a comment - I removed the "gem update --system" line from the Windows instructions.
        Hide
        Antoine Toulme added a comment -

        It is a general issue with Rubygems, for which we changed the doc a bit. Hopefully we won't have this problem anymore.

        Show
        Antoine Toulme added a comment - It is a general issue with Rubygems, for which we changed the doc a bit. Hopefully we won't have this problem anymore.
        Antoine Toulme made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Antoine Toulme [ toulmean ]
        Resolution Won't Fix [ 2 ]
        Hide
        Ciaran Jessup added a comment -

        In case this bites someone else, it is NOT sufficient to just download the 1.8.7 one-click installer. You must download an early version of it, for example: http://rubyforge.org/frs/download.php/74293/rubyinstaller-1.8.7-p334.exe works whereas any later versions do not.

        Show
        Ciaran Jessup added a comment - In case this bites someone else, it is NOT sufficient to just download the 1.8.7 one-click installer. You must download an early version of it, for example: http://rubyforge.org/frs/download.php/74293/rubyinstaller-1.8.7-p334.exe works whereas any later versions do not.
        Peter Donald made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hide
        tom chiverton added a comment -

        This is still broken today in the latest http://files.rubyforge.vm.bytemark.co.uk/rubyinstaller/rubyinstaller-1.8.7-p371.exe download, a year later, only now it is broken immediately, not by the gem update.

        Show
        tom chiverton added a comment - This is still broken today in the latest http://files.rubyforge.vm.bytemark.co.uk/rubyinstaller/rubyinstaller-1.8.7-p371.exe download, a year later, only now it is broken immediately, not by the gem update.

          People

          • Assignee:
            Antoine Toulme
            Reporter:
            Jesse Tomlinson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development