Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Won't Fix
    • Affects Version/s: 1.4.5
    • Fix Version/s: 1.4.7
    • Component/s: None
    • Labels:
      None
    • Environment:
      Window 7 64 bit

      Description

      The install documentation says to "Be sure to install Ruby 1.8.6", but after installing that and running "gem update --system", that will give you an error saying it needs to have Ruby 1.8.7. After installing 1.8.7, doing the "gem update --system", installing buildr, and trying any command with "buildr" (i.e. "buildr --version", "buildr --help", "buildr") it give the following error:

      C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:926:in `report_activate_error': RubyGem version error: buildr(1.4.5 not >= 0) (Gem::LoadError)
      from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:244:in `activate_dep'
      from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:236:in `activate'
      from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:1307:in `gem'
      from C:/Ruby187/bin/buildr:18

      C:\>gem list

          • LOCAL GEMS ***

      atoulme-Antwrap (0.7.1)
      builder (2.1.2)
      buildr (1.4.5 x86-mswin32)
      diff-lcs (1.1.2)
      highline (1.5.1)
      hoe (2.3.3)
      json_pure (1.4.3)
      minitar (0.5.3)
      net-sftp (2.0.4)
      net-ssh (2.0.23)
      rake (0.8.7)
      rjb (1.3.2 x86-mswin32-60)
      rspec (2.1.0)
      rspec-core (2.1.0)
      rspec-expectations (2.1.0)
      rspec-mocks (2.1.0)
      rubyforge (2.0.3)
      rubygems-update (1.7.2)
      rubyzip (0.9.4)
      xml-simple (1.0.12)

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Antoine Toulme
            Reporter:
            Jesse Tomlinson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development