Bigtop
  1. Bigtop
  2. BIGTOP-947

oozie init script does not use JAVA_HOME in /etc/default/bigtop-utils

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.5.0
    • Fix Version/s: 0.6.0
    • Component/s: Init scripts
    • Labels:
      None

      Description

      I set JAVA_HOME in /etc/default/bigtop-utils.
      Then I started various services (hadoop-hdfs, hadoop-mapreduce, etc).
      I found that the oozie server (which I start using the init script, by doing "service oozie start") does not use the JAVA_HOME I set; it uses /usr/bin/java.

        Activity

        Wing Yew Poon added a comment -

        I believe this affects the services that run on Tomcat, e.q., sqoop2 (which I do not currently use).

        Sean Mackrory added a comment -

        Wing Yew,

        I recently had this same problem and fixed it in BIGTOP-888. May I ask you to try applying that change to /etc/init.d/oozie on your existing installation to verify that it's the same problem?

        If it is the same problem, it won't be specific to Tomcat, as we were killing the environment before making it as far as Tomcat. If it's different however, I can investigate both Oozie and Sqoop further.

        Wing Yew Poon added a comment -

        Sean, thanks. The change you made for BIGTOP-888 fixed the issue for oozie. With it, oozie is using the java from the JAVA_HOME I specify in /etc/default/bigtop-utils.

        Mark Grover added a comment -

        Duplicate of BIGTOP-888


          People

          • Assignee:
            Unassigned
            Reporter:
            Wing Yew Poon
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development