Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6.0
    • Fix Version/s: 0.6.0
    • Component/s: tests
    • Labels:
      None

      Activity

      Johnny Zhang created issue -
      Johnny Zhang added a comment -

      this should fix the crunch package test failures. Still looking into other failures.

      Johnny Zhang made changes -
      Field Original Value New Value
      Attachment BIGTOP-859.patch [ 12571688 ]
      Johnny Zhang added a comment - - edited

      I think this is only code change required in package tests. This patch should reduce 30+ failures.

      For rest of the failures, it is about env issue (either mirror or repo's slow response cause failures):
      1. I kick off the test job several times, beside the crunch failures, other failures are all random pass or regression in next run. In the job log, cannot find the failures message.

      2. I manually cannot reproduce other failures except the crunch failures.
      Actually, I try to run the same test on one VM, sometimes, I got initialize error that test even cannot be started, sometimes tests kicked off but some random test cases fail.

      The random failures are from:
      testPackageMetadata
      testAlternatives
      testPackageInstall

      I haven't figure out how to fix the env/job though

      Johnny Zhang made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Roman Shaposhnik added a comment -

      +1 and committed! Johnny, in the future, could you please attach patches generated via 'git format-patch' ? Thanks!

      Roman Shaposhnik made changes -
      Status Patch Available [ 10002 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Roman Shaposhnik made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open Patch Available Patch Available
      9d 19h 42m 1 Johnny Zhang 11/Mar/13 18:39
      Patch Available Patch Available Resolved Resolved
      4d 2h 4m 1 Roman Shaposhnik 15/Mar/13 20:44
      Resolved Resolved Closed Closed
      98d 3h 5m 1 Roman Shaposhnik 22/Jun/13 00:49

        People

        • Assignee:
          Johnny Zhang
          Reporter:
          Johnny Zhang
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development