Bigtop
  1. Bigtop
  2. BIGTOP-626

small misc. issues with the newly introduced Giraph package

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.4.0
    • Component/s: general
    • Labels:
      None

      Description

      After running deployment tests I've noticed that:

      • Giraph dependencies need to be updated (Zookeeper, possibly Mahout?)
      • A small typo in the DEB description needs to be fixed
      • Puppet code needs to honor cluster-wide ZK ensemble setting
      • Tests need to timeout
      1. BIGTOP-626.patch.txt
        6 kB
        Roman Shaposhnik

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          3d 5h 5m 1 Roman Shaposhnik 15/Jun/12 20:28
          Patch Available Patch Available Resolved Resolved
          8s 1 Roman Shaposhnik 15/Jun/12 20:28
          Resolved Resolved Closed Closed
          371d 3h 26m 1 Roman Shaposhnik 21/Jun/13 23:55
          Roman Shaposhnik made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Roman Shaposhnik made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Roman Shaposhnik made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Eugene Koontz made changes -
          Link This issue relates to BIGTOP-570 [ BIGTOP-570 ]
          Hide
          Bruno Mahé added a comment -

          +1

          Show
          Bruno Mahé added a comment - +1
          Hide
          Andrew Purtell added a comment -
          +# Enforcing dependency on the Bigtop's version of Zookeeper
          +ln -fs /usr/lib/zookeeper/zookeeper.jar $PREFIX/$LIB_DIR/lib/zookeeper*.jar
          

          Or override in do-component-build with -Dzookeeper.version=foo? That's not working?

          +  @Test(timeout=300000L)
          

          Will remember this detail in the future.

          Show
          Andrew Purtell added a comment - +# Enforcing dependency on the Bigtop's version of Zookeeper +ln -fs /usr/lib/zookeeper/zookeeper.jar $PREFIX/$LIB_DIR/lib/zookeeper*.jar Or override in do-component-build with -Dzookeeper.version=foo? That's not working? + @Test(timeout=300000L) Will remember this detail in the future.
          Roman Shaposhnik made changes -
          Attachment BIGTOP-626.patch.txt [ 12531869 ]
          Roman Shaposhnik made changes -
          Attachment BIGTOP-626.patch.txt [ 12531868 ]
          Roman Shaposhnik made changes -
          Field Original Value New Value
          Attachment BIGTOP-626.patch.txt [ 12531868 ]
          Hide
          Roman Shaposhnik added a comment -

          Andrew, you can review the attached patch

          Show
          Roman Shaposhnik added a comment - Andrew, you can review the attached patch
          Hide
          Andrew Purtell added a comment -

          Anything I can help out here with Roman?

          Show
          Andrew Purtell added a comment - Anything I can help out here with Roman?
          Roman Shaposhnik created issue -

            People

            • Assignee:
              Roman Shaposhnik
              Reporter:
              Roman Shaposhnik
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development