Bigtop
  1. Bigtop
  2. BIGTOP-518

Oozie missing doxia-module-twiki:jar:1.0-alpha-9.2 and doxia-module-twiki:jar:1.0-alpha-9.2y

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not a Problem
    • Affects Version/s: 0.3.0
    • Fix Version/s: 0.3.1
    • Component/s: Debian
    • Labels:
      None
    • Environment:

      all

      Description

      bad repo

        Activity

        Hide
        doug chang added a comment - - edited

        When Oozie is building:
        Downloading: http://yahoo.github.com/maven/repository/org/apache/maven/doxia/doxia-module-twiki/1.0-alpha-9.2y/doxia-module-twiki-1.0-alpha-9.2y.jar
        Downloading: http://yahoo.github.com/maven/repository/org/apache/maven/doxia/doxia-core/1.0-alpha-9.2y/doxia-core-1.0-alpha-9.2y.jar

        the path doesnt exist anymore. upstream component. This isn't a bigtop issue, bug in Oozie pom:

        <pluginRepository>
        <id>yahoo.github</id>
        <url>http://yahoo.github.com/maven/repository</url>
        <snapshots>
        <enabled>true</enabled>
        </snapshots>
        </pluginRepository>

        repo entry in oozie 3.3.1 is invalid

        to modify the doxia version under oozie-3.3.1/docs/pom.xml, unzip the oozie_3.1.3-1.orig.tar.gz, change the doxia version from alpha-9.2y to alpha-9, then retar and zip up. Modify the file oozie-3.3.1-1.dsc according to attached word doc.

        Show
        doug chang added a comment - - edited When Oozie is building: Downloading: http://yahoo.github.com/maven/repository/org/apache/maven/doxia/doxia-module-twiki/1.0-alpha-9.2y/doxia-module-twiki-1.0-alpha-9.2y.jar Downloading: http://yahoo.github.com/maven/repository/org/apache/maven/doxia/doxia-core/1.0-alpha-9.2y/doxia-core-1.0-alpha-9.2y.jar the path doesnt exist anymore. upstream component. This isn't a bigtop issue, bug in Oozie pom: <pluginRepository> <id>yahoo.github</id> <url> http://yahoo.github.com/maven/repository </url> <snapshots> <enabled>true</enabled> </snapshots> </pluginRepository> repo entry in oozie 3.3.1 is invalid to modify the doxia version under oozie-3.3.1/docs/pom.xml, unzip the oozie_3.1.3-1.orig.tar.gz, change the doxia version from alpha-9.2y to alpha-9, then retar and zip up. Modify the file oozie-3.3.1-1.dsc according to attached word doc.
        Hide
        Konstantin Boudnik added a comment - - edited

        Hmm, I assume it could be addressed by a "normal" BigTop way of slipping in an appropriate patch into component's package directory bigtop-packages/src/common/oozie. In this particular case it would be OOZIE-810's patch.

        Show
        Konstantin Boudnik added a comment - - edited Hmm, I assume it could be addressed by a "normal" BigTop way of slipping in an appropriate patch into component's package directory bigtop-packages/src/common/oozie . In this particular case it would be OOZIE-810 's patch.
        Hide
        Konstantin Boudnik added a comment -

        With upgrading to Oozie 3.3.1 this won't be a problem anymore.

        Show
        Konstantin Boudnik added a comment - With upgrading to Oozie 3.3.1 this won't be a problem anymore.

          People

          • Assignee:
            Unassigned
            Reporter:
            doug chang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development