Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-3352

Fix qfs build error on Ubuntu 18.04

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.0
    • Component/s: None
    • Labels:
      None

      Description

      qfs build failed on ubuntu18.04

      > Task :qfs-sdeb FAILED
      dpkg-buildpackage: info: source package qfs
      dpkg-buildpackage: info: source version 2.0.0-1
      dpkg-buildpackage: info: source distribution stable
      dpkg-buildpackage: info: source changed by Bigtop <dev@bigtop.apache.org>
       dpkg-source --before-build qfs-2.0.0
      dpkg-source: info: applying patch0-gf_cpu.diff
      dpkg-source: info: applying patch1-maven-surefire.diff
      dpkg-checkbuilddeps: error: Unmet build dependencies: dh-python
      dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
      dpkg-buildpackage: warning: (Use -d flag to override.)
      
      

        Attachments

          Activity

            People

            • Assignee:
              yqGu Yuqi Gu
              Reporter:
              yqGu Yuqi Gu
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h