Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-3330

oozie and oozie-client deb packages try to install the same jars in the same dir

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 1.4.0
    • 1.5.0
    • None
    • None

    Description

      Hi!

      While installing oozie I get the following error:

      
      Unpacking oozie (4.3.0-2) ...
       dpkg: error processing archive /var/cache/apt/archives/oozie_4.3.0-2_all.deb (--unpack):
       trying to overwrite '/usr/lib/oozie/lib/accessors-smart-1.2.jar', which is also in package oozie-client 4.3.0-2
       dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
       Errors were encountered while processing:
       /var/cache/apt/archives/oozie_4.3.0-2_all.deb
       E: Sub-process /usr/bin/dpkg returned an error code (1)
      
      

      It can be resolved with the following:

      
      dpkg -i --force-overwrite /var/cache/apt/archives/oozie_4.3.0-2_all.deb
      (Reading database ... 106775 files and directories currently installed.)
      Preparing to unpack .../archives/oozie_4.3.0-2_all.deb ...
      Unpacking oozie (4.3.0-2) ...
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/accessors-smart-1.2.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/activemq-client-5.13.3.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/apacheds-i18n-2.0.0-M15.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/apacheds-kerberos-codec-2.0.0-M15.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/api-asn1-api-1.0.0-M20.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/api-util-1.0.0-M20.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/asm-5.0.4.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/commons-cli-1.2.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/commons-codec-1.4.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/commons-logging-1.1.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/curator-client-2.5.0.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/curator-framework-2.5.0.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/geronimo-j2ee-management_1.1_spec-1.0.1.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/geronimo-jms_1.1_spec-1.1.1.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/guava-11.0.2.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/hawtbuf-1.11.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/httpclient-4.3.6.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/httpcore-4.3.3.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/jackson-core-asl-1.9.13.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/jackson-mapper-asl-1.9.13.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/jcip-annotations-1.0-1.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/jline-0.9.94.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/json-simple-1.1.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/json-smart-2.3.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/jsr305-1.3.9.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/netty-3.7.0.Final.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/nimbus-jose-jwt-4.41.1.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/oozie-client-4.3.0.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/oozie-hadoop-auth-hadoop-2-4.3.0.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/slf4j-api-1.6.6.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/slf4j-simple-1.6.6.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/xercesImpl-2.10.0.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/xml-apis-1.4.01.jar', which is also in package oozie-client 4.3.0-2
      dpkg: warning: overriding problem because --force enabled:
      dpkg: warning: trying to overwrite '/usr/lib/oozie/lib/zookeeper-3.4.6.jar', which is also in package oozie-client 4.3.0-2
      dpkg: dependency problems prevent configuration of oozie:
       oozie depends on oozie-client (= 4.3.0-2); however:
       Package oozie-client is not configured yet.
      
      

      And then a subsequent apt-get --force install oozie, but the packages oozie and oozie-client shouldn't overlap in this way. I am not super expert in finding where these jars are added but I can offer any help to fix this

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            elukey Luca Toscano
            elukey Luca Toscano
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 1h
                1h

                Slack

                  Issue deployment