Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-3123 Define Bigtop 1.5.0 release BOM
  3. BIGTOP-3277

Update deploy manifests to support newly added distros in v1.5.0

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.4.0
    • Fix Version/s: None
    • Component/s: deployment
    • Labels:
      None

      Description

      The current deploy manifests seem to work with most of distros we support in v1.5.0 as they are, but we have to address at least the following issues on Debian 10:

      1. In case that JDK is not pre-installed, the current bigtop-deploy/puppet/manifests/jdk.pp doesn't work. It should be fixed as BIGTOP-3343.

      Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install openjdk-8-jdk' returned 100: Reading package lists...
      Building dependency tree...
      Reading state information...
      E: Unable to locate package openjdk-8-jdk
      Error: /Stage[main]/Jdk/Package[jdk]/ensure: change from 'purged' to 'present' failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install openjdk-8-jdk' returned 100: Reading package lists...
      Building dependency tree...
      Reading state information...
      E: Unable to locate package openjdk-8-jdk
      

      2. Debian 10 has a "zookeeper" package by default, so we have to give ours higher priority somehow.

      Error: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install zookeeper-server' returned 100: Reading package lists...
      Building dependency tree...
      Reading state information...
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      
      The following packages have unmet dependencies:
       zookeeper-server : Depends: zookeeper (= 3.4.13-1) but 3.4.13-2 is to be installed
      E: Unable to correct problems, you have held broken packages.
      Error: /Stage[main]/Hadoop_zookeeper::Server/Package[zookeeper-server]/ensure: change from 'purged' to 'latest' failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install zookeeper-server' returned 100: Reading package lists...
      Building dependency tree...
      Reading state information...
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      
      The following packages have unmet dependencies:
       zookeeper-server : Depends: zookeeper (= 3.4.13-1) but 3.4.13-2 is to be installed
      E: Unable to correct problems, you have held broken packages.
      

        Attachments

          Activity

            People

            • Assignee:
              sekikn Kengo Seki
              Reporter:
              sekikn Kengo Seki
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: