Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-3162 Define Bigtop 1.4.0 release BOM
  3. BIGTOP-3215

Failed to build bigtop/puppet image for OpenSuSE

    XMLWordPrintableJSON

    Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.0
    • Fix Version/s: 1.5.0
    • Component/s: docker
    • Labels:
      None

      Description

      Started by upstream project "Docker-Puppet-1.4.0" build number 2
      originally caused by:
       Started by user Evans Ye
      Building remotely on docker-slave-arm-5 (ubuntu-16.04-arm64-deploy fedora-26-aarch64-deploy aarch64-slave debian-9-arm64-deploy centos-7-aarch64 debian-9-aarch64) in workspace /home/jenkins/workspace/Docker-Puppet-1.4.0/DISTRO/opensuse-42.3/PLATFORM/aarch64-slave
      Cloning the remote Git repository
      Cloning repository https://gitbox.apache.org/repos/asf/bigtop.git
       > git init /home/jenkins/workspace/Docker-Puppet-1.4.0/DISTRO/opensuse-42.3/PLATFORM/aarch64-slave # timeout=10
      Fetching upstream changes from https://gitbox.apache.org/repos/asf/bigtop.git
       > git --version # timeout=10
       > git fetch --tags --progress https://gitbox.apache.org/repos/asf/bigtop.git +refs/heads/*:refs/remotes/origin/*
       > git config remote.origin.url https://gitbox.apache.org/repos/asf/bigtop.git # timeout=10
       > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
       > git config remote.origin.url https://gitbox.apache.org/repos/asf/bigtop.git # timeout=10
      Fetching upstream changes from https://gitbox.apache.org/repos/asf/bigtop.git
       > git fetch --tags --progress https://gitbox.apache.org/repos/asf/bigtop.git +refs/heads/*:refs/remotes/origin/*
      Checking out Revision 51e0436e239b2bebbb4edda1b53117913b49703d (origin/branch-1.4)
       > git config core.sparsecheckout # timeout=10
       > git checkout -f 51e0436e239b2bebbb4edda1b53117913b49703d
      Commit message: "Bigtop 1.4.0 release"
       > git rev-list --no-walk c52b9b7bc77d0b04df6530fb285c23e8fbc2db12 # timeout=10
      [aarch64-slave] $ /bin/bash /tmp/jenkins5808019095228182779.sh
      ++ uname -m
      + ARCH=aarch64
      + case "$ARCH" in
      + POSTFIX=-aarch64
      + NETWORK='--network host'
      + cd docker/bigtop-puppet
      + sed -i 's/docker build/docker build --network host --no-cache --rm/' build.sh
      + ./build.sh 1.4.0-opensuse-42.3
      ++ '[' 1 '!=' 1 ']'
      +++ echo 1.4.0-opensuse-42.3
      +++ cut -d - -f 1
      ++ PREFIX=1.4.0
      +++ echo 1.4.0-opensuse-42.3
      +++ cut -d - -f 2
      ++ OS=opensuse
      +++ echo 1.4.0-opensuse-42.3
      +++ cut -d - -f 3
      ++ VERSION=42.3
      +++ uname -m
      ++ ARCH=aarch64
      ++ '[' aarch64 '!=' x86_64 ']'
      ++ ARCH=-aarch64
      ++ cp ../../bigtop_toolchain/bin/puppetize.sh .
      ++ cat
      ++ docker build --network host --no-cache --rm -t bigtop/puppet:1.4.0-opensuse-42.3-aarch64 .
      Sending build context to Docker daemon  7.168kB
      
      Step 1/4 : FROM opensuse:42.3
      42.3: Pulling from library/opensuse
      5f2597b0284c: Pulling fs layer
      5f2597b0284c: Download complete
      5f2597b0284c: Pull complete
      Digest: sha256:81451bd26b48a2521db953e6376aebb5e0f55d429627017ba728219d48112f40
      Status: Downloaded newer image for opensuse:42.3
       ---> 0fd969d14cdd
      Step 2/4 : MAINTAINER dev@bigtop.apache.org
       ---> Running in 2a7a594f7d60
      Removing intermediate container 2a7a594f7d60
       ---> e53a501410b5
      Step 3/4 : COPY puppetize.sh /tmp/puppetize.sh
       ---> 20cac5eba358
      Step 4/4 : RUN bash /tmp/puppetize.sh
       ---> Running in efda7b2cdc78
      Retrieving repository 'OSS' metadata [.....done]
      Building repository 'OSS' cache [....done]
      Retrieving repository 'OSS Update' metadata [.done]
      Building repository 'OSS Update' cache [....done]
      Loading repository data...
      Reading installed packages...
      'ca-certificates-mozilla' is already installed.
      No update candidate for 'ca-certificates-mozilla-2.22-12.1.noarch'. The highest available version is already installed.
      'puppet' not found in package names. Trying capabilities.
      'suse-release' not found in package names. Trying capabilities.
      'openSUSE-release' providing 'suse-release' is already installed.
      Resolving package dependencies...
      
      Problem: systemd-sysvinit-228-27.1.aarch64 requires systemd = 228-27.1, but this requirement cannot be provided
        uninstallable providers: systemd-228-27.1.aarch64[OSS]
                         systemd-228-27.1.aarch64[OSS Update]
       Solution 1: downgrade of systemd-228-47.1.aarch64 to systemd-228-27.1.aarch64
       Solution 2: do not install systemd-sysvinit-228-27.1.aarch64
       Solution 3: break systemd-sysvinit-228-27.1.aarch64 by ignoring some of its dependencies
      
      Choose from above solutions by number or cancel [1/2/3/c] (c): c
      /tmp/puppetize.sh: line 39: puppet: command not found
      The command '/bin/sh -c bash /tmp/puppetize.sh' returned a non-zero code: 127
      Build step 'Execute shell' marked build as failure
      Finished: FAILURE
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                evans_ye Evans Ye
                Reporter:
                evans_ye Evans Ye
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h