Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2751

ambari: Storm 1.1.0-SNAPSHOT is no longer available, use released version

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.1
    • Component/s: None
    • Labels:
      None

      Description

      Thanks to Arnaud Launay for pointing out : ambari does not compile

      [ERROR] Failed to execute goal on project ambari-metrics-storm-sink: Could not resolve dependencies for project org.apache.ambari:ambari-metrics-storm-sink:jar:2.5.0.0.0: Could not find artifact org.apache.storm:storm-core:jar:1.1.0-SNAPSHOT in apache-hadoop (http://repo.hortonworks.com/content/groups/public/) -> [Help 1]
      

        Activity

        sekikn Kengo Seki added a comment -

        Thanks Arnaud Launay and Olaf Flebbe, committed and pushed to master.

        sekikn Kengo Seki added a comment -

        I tested the patch on Ubuntu 16.04 and confirmed that it worked. +1 and will commit shortly.
        BTW, after applying it, I got another error:

        $ ./gradlew ambari-pkg
        
        (snip)
        
        [INFO] -------------------------------------------------------------
        [ERROR] COMPILATION ERROR :
        [INFO] -------------------------------------------------------------
        [ERROR] /home/sekikn/dev/bigtop/output/ambari/ambari-2.5.0/ambari-server/src/main/java/org/apache/ambari/server/state/svccomphost/ServiceComponentHostImpl.java:[80,37] package org.jboss.netty.util.internal does not exist
        [ERROR] /home/sekikn/dev/bigtop/output/ambari/ambari-2.5.0/ambari-server/src/main/java/org/apache/ambari/server/state/svccomphost/ServiceComponentHostImpl.java:[155,65] cannot find symbol
          symbol:   class ConcurrentHashMap
          location: class org.apache.ambari.server.state.svccomphost.ServiceComponentHostImpl
        [ERROR] /home/sekikn/dev/bigtop/output/ambari/ambari-2.5.0/ambari-server/src/main/java/org/apache/ambari/server/state/svccomphost/ServiceComponentHostImpl.java:[1427,68] cannot find symbol
          symbol:   class ConcurrentHashMap
          location: class org.apache.ambari.server.state.svccomphost.ServiceComponentHostImpl
        [INFO] 3 errors
        [INFO] -------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Summary:
        [INFO]
        [INFO] Ambari Main ........................................ SUCCESS [  2.090 s]
        [INFO] Apache Ambari Project POM .......................... SUCCESS [  0.019 s]
        [INFO] Ambari Web ......................................... SUCCESS [03:41 min]
        [INFO] Ambari Views ....................................... SUCCESS [  2.375 s]
        [INFO] Ambari Admin View .................................. SUCCESS [02:57 min]
        [INFO] utility ............................................ SUCCESS [  0.864 s]
        [INFO] ambari-metrics ..................................... SUCCESS [  0.345 s]
        [INFO] Ambari Metrics Common .............................. SUCCESS [  6.724 s]
        [INFO] Ambari Metrics Hadoop Sink ......................... SUCCESS [  4.916 s]
        [INFO] Ambari Metrics Flume Sink .......................... SUCCESS [  2.671 s]
        [INFO] Ambari Metrics Kafka Sink .......................... SUCCESS [  2.251 s]
        [INFO] Ambari Metrics Storm Sink .......................... SUCCESS [  4.361 s]
        [INFO] Ambari Metrics Storm Sink (Legacy) ................. SUCCESS [  3.241 s]
        [INFO] Ambari Metrics Collector ........................... SUCCESS [18:25 min]
        [INFO] Ambari Metrics Monitor ............................. SUCCESS [  1.233 s]
        [INFO] Ambari Metrics Grafana ............................. SUCCESS [03:54 min]
        [INFO] Ambari Metrics Assembly ............................ SUCCESS [08:57 min]
        [INFO] Ambari Server ...................................... FAILURE [ 11.895 s]
        [INFO] Ambari Functional Tests ............................ SKIPPED
        [INFO] Ambari Agent ....................................... SKIPPED
        [INFO] Ambari Client ...................................... SKIPPED
        [INFO] Ambari Python Client ............................... SKIPPED
        [INFO] Ambari Groovy Client ............................... SKIPPED
        [INFO] Ambari Shell ....................................... SKIPPED
        [INFO] Ambari Python Shell ................................ SKIPPED
        [INFO] Ambari Groovy Shell ................................ SKIPPED
        [INFO] ambari-logsearch ................................... SKIPPED
        [INFO] Ambari Logsearch Appender .......................... SKIPPED
        [INFO] Ambari Logsearch Portal ............................ SKIPPED
        [INFO] Ambari Logsearch Log Feeder ........................ SKIPPED
        [INFO] Ambari Logsearch Solr Client ....................... SKIPPED
        [INFO] Ambari Infra Solr Plugin ........................... SKIPPED
        [INFO] Ambari Logsearch Assembly .......................... SKIPPED
        [INFO] Ambari Logsearch Integration Test .................. SKIPPED
        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD FAILURE
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 38:40 min
        [INFO] Finished at: 2017-05-22T03:12:32-04:00
        [INFO] Final Memory: 155M/1022M
        [INFO] ------------------------------------------------------------------------
        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.2:compile (default-compile) on project ambari-server: Compilation failure: Compilation failure:
        [ERROR] /home/sekikn/dev/bigtop/output/ambari/ambari-2.5.0/ambari-server/src/main/java/org/apache/ambari/server/state/svccomphost/ServiceComponentHostImpl.java:[80,37] package org.jboss.netty.util.internal does not exist
        [ERROR] /home/sekikn/dev/bigtop/output/ambari/ambari-2.5.0/ambari-server/src/main/java/org/apache/ambari/server/state/svccomphost/ServiceComponentHostImpl.java:[155,65] cannot find symbol
        [ERROR] symbol:   class ConcurrentHashMap
        [ERROR] location: class org.apache.ambari.server.state.svccomphost.ServiceComponentHostImpl
        [ERROR] /home/sekikn/dev/bigtop/output/ambari/ambari-2.5.0/ambari-server/src/main/java/org/apache/ambari/server/state/svccomphost/ServiceComponentHostImpl.java:[1427,68] cannot find symbol
        [ERROR] symbol:   class ConcurrentHashMap
        [ERROR] location: class org.apache.ambari.server.state.svccomphost.ServiceComponentHostImpl
        [ERROR] -> [Help 1]
        [ERROR]
        [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
        [ERROR] Re-run Maven using the -X switch to enable full debug logging.
        [ERROR]
        [ERROR] For more information about the errors and possible solutions, please read the following articles:
        [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
        [ERROR]
        [ERROR] After correcting the problems, you can resume the build with the command
        [ERROR]   mvn <goals> -rf :ambari-server
        debian/rules:29: recipe for target 'override_dh_auto_build' failed
        

        This error seems to be caused by using org.jboss.netty.util.internal.ConcurrentHashMap instead of java.util.concurrent.ConcurrentHashMap unnecessarily.
        Actually, a patch submitted to AMBARI-20827 solved this issue. I'll file it as another JIRA.


          People

          • Assignee:
            oflebbe Olaf Flebbe
            Reporter:
            oflebbe Olaf Flebbe
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development