Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2750

puppet: increase compatibility with future versions

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.1, 1.3.0
    • Component/s: deployment
    • Labels:
      None

      Description

      There are a few minor glitches which are not compatible with puppet4, which are not absolutly legit before.

        Activity

        Hide
        oflebbe Olaf Flebbe added a comment -

        Roman Shaposhnik thanx for the review

        Show
        oflebbe Olaf Flebbe added a comment - Roman Shaposhnik thanx for the review
        Hide
        rvs Roman Shaposhnik added a comment -

        This looks very reasonable to me. Thanks for getting this going!

        Show
        rvs Roman Shaposhnik added a comment - This looks very reasonable to me. Thanks for getting this going!
        Hide
        oflebbe Olaf Flebbe added a comment -

        with this patch and additionally the patches from the puppet4 branch deployment worked for me.

        Show
        oflebbe Olaf Flebbe added a comment - with this patch and additionally the patches from the puppet4 branch deployment worked for me.
        Hide
        oflebbe Olaf Flebbe added a comment -

        downcase is in stdlib

        use proper package qualifier

        Show
        oflebbe Olaf Flebbe added a comment - downcase is in stdlib use proper package qualifier

          People

          • Assignee:
            oflebbe Olaf Flebbe
            Reporter:
            oflebbe Olaf Flebbe
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development