Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2651

Delete obsolete docker images and build files.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: build
    • Labels:
      None

      Description

      I propose to remove ubuntu-15.04, fedora-20, opensuse-13.2 from our build system scripts.

      1. BIGTOP-2651.2.patch
        19 kB
        Olaf Flebbe
      2. BIGTOP-2651.3.patch
        20 kB
        Olaf Flebbe

        Issue Links

          Activity

          Hide
          oflebbe Olaf Flebbe added a comment -

          BTW: Obsolete means, not maintained any more by the original distributor

          Show
          oflebbe Olaf Flebbe added a comment - BTW: Obsolete means, not maintained any more by the original distributor
          Hide
          asanjar Amir Sanjar added a comment -

          +1, finally
          also update bigtop_toolchain/bin/puppetize.sh

          Show
          asanjar Amir Sanjar added a comment - +1, finally also update bigtop_toolchain/bin/puppetize.sh
          Hide
          oflebbe Olaf Flebbe added a comment -

          Ooops patch was incorrect

          Show
          oflebbe Olaf Flebbe added a comment - Ooops patch was incorrect
          Hide
          oflebbe Olaf Flebbe added a comment -

          Ah yes, thanks! Will update puppetize as well

          Show
          oflebbe Olaf Flebbe added a comment - Ah yes, thanks! Will update puppetize as well
          Hide
          oflebbe Olaf Flebbe added a comment -

          Updated patch with removal of fedora 20 and updating ubuntu to a catch all (for supporting ubuntu 1[78].04

          I propose to remove the ubuntu-15.04 docker images as well:

          bigtop/puppet:ubuntu-15.04*
          

          And these unversioned obsolete images

          bigtop/slaves:ubuntu-12.04
          bigtop/slaves:centos-6.4
          bigtop/slaves:opensuse-12.3
          bigtop/slaves:ubuntu-10.04
          bigtop/slaves:ubuntu-14.04
          bigtop/slaves:opensuse-13.2
          bigtop/slaves:fedora-20
          bigtop/slaves:debian-8
          bigtop/slaves:centos-7
          bigtop/slaves:centos-6
          

          And these now obsolete trunk images

          bigtop/slaves:trunk-fedora-20
          bigtop/slaves:trunk-ubuntu-15.04
          bigtop/slaves:trunk-opensuse-13.2
          bigtop/slaves:trunk-ubuntu-15.04-ppc64le
          
          Show
          oflebbe Olaf Flebbe added a comment - Updated patch with removal of fedora 20 and updating ubuntu to a catch all (for supporting ubuntu 1 [78] .04 I propose to remove the ubuntu-15.04 docker images as well: bigtop/puppet:ubuntu-15.04* And these unversioned obsolete images bigtop/slaves:ubuntu-12.04 bigtop/slaves:centos-6.4 bigtop/slaves:opensuse-12.3 bigtop/slaves:ubuntu-10.04 bigtop/slaves:ubuntu-14.04 bigtop/slaves:opensuse-13.2 bigtop/slaves:fedora-20 bigtop/slaves:debian-8 bigtop/slaves:centos-7 bigtop/slaves:centos-6 And these now obsolete trunk images bigtop/slaves:trunk-fedora-20 bigtop/slaves:trunk-ubuntu-15.04 bigtop/slaves:trunk-opensuse-13.2 bigtop/slaves:trunk-ubuntu-15.04-ppc64le
          Hide
          oflebbe Olaf Flebbe added a comment -

          Committed

          Show
          oflebbe Olaf Flebbe added a comment - Committed

            People

            • Assignee:
              oflebbe Olaf Flebbe
              Reporter:
              oflebbe Olaf Flebbe
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development