Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2628

sqoop2 build fails when JAVA 8 is used

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: build
    • Labels:
      None

      Description

      sample build error msg:
      ERROR] /ws/build/sqoop2/rpm/BUILD/sqoop-1.99.4/common/src/main/java/org/apache/sqoop/common/VersionAnnotation.java:50: warning: no @return
      [ERROR] String url();
      [ERROR] ^
      [ERROR] /ws/build/sqoop2/rpm/BUILD/sqoop-1.99.4/common/src/main/java/org/apache/sqoop/common/VersionAnnotation.java:39: warning: no @return
      [ERROR] String user();
      [ERROR] ^
      [ERROR] /ws/build/sqoop2/rpm/BUILD/sqoop-1.99.4/common/src/main/java/org/apache/sqoop/etl/io/DataReader.java:29: warning: no description for @throws
      [ERROR] * @throws Exception
      [ERROR] ^
      [ERROR] /ws/build/sqoop2/rpm/BUILD/sqoop-1.99.4/common/src/main/java/org/apache/sqoop/etl/io/DataReader.java:37: warning: no description for @throws
      [ERROR] * @throws Exception
      [ERROR] ^
      [ERROR] /ws/build/sqoop2/rpm/BUILD/sqoop-1.99.4/common/src/main/java/org/apache/sqoop/etl/io/DataReader.java:45: warning: no description for @throws
      [ERROR] * @throws Exception
      [ERROR] ^

        Issue Links

          Activity

          oflebbe Olaf Flebbe added a comment -

          will try if updating resolves this issue.

          oflebbe Olaf Flebbe added a comment - - edited

          This build break is fixed in squoop 1.99.7. But package construction fails...

          Oops that's a major rewrite. They removed the tomcat webapp and moved to a Jetty Server,

          Updating sqoop should be handled in BIGTOP-1844

          oflebbe Olaf Flebbe added a comment -

          Will try to set the sqoop JDK to 1.7 for now.

          oflebbe Olaf Flebbe added a comment -

          Hi Amir Sanjar, I cannot reproduce the error you see . Will close the bug as cannot reproduce.
          Please reopen, if you still see the problem (after updating bigtop/slaves docker image)

          oflebbe Olaf Flebbe added a comment -

          replaced fedora-20 with fedora-25 on default Bigtop-trunk-packages build.
          We will see problems tomorrow.

          oflebbe Olaf Flebbe added a comment -

          That's interesting. It fails on Redhat platforms only. And it fails to compile with in comments.

          oflebbe Olaf Flebbe added a comment - - edited

          Crap, this is javadoc failing. We have javadoc from 1.8.0 in our redhat images and javadoc from 1.7.0 in the rest. Will try workaround to disable doclint.

          No: javadoc is not triggered by the pom.xml it is run from the command line without further configuration. So this is kind of explanation why it only fails on some platforms.

          Solution is to remove javadoc:jar from the command line since it is not needed by packaging.

          oflebbe Olaf Flebbe added a comment -

          Committed


            People

            • Assignee:
              oflebbe Olaf Flebbe
              Reporter:
              asanjar Amir Sanjar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development